# Record of Revisions

Reference numbers are shown at the bottom left corner on the back cover of each manual.

<table>
<thead>
<tr>
<th>Creation Date</th>
<th>Reference No.</th>
<th>Revised Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>April, 2013</td>
<td>1203NE0</td>
<td>First edition</td>
</tr>
</tbody>
</table>
Preface

Thank you for purchasing the Techno Shot Series monitor (hereafter referred to as "TS Series"). Thoroughly read and understand the contents of this manual to ensure correct usage of the TS Series unit. The following manuals relate to the TS Series unit. Reference these manuals as required.

<table>
<thead>
<tr>
<th>Manual Name</th>
<th>Description</th>
<th>Reference No.</th>
</tr>
</thead>
<tbody>
<tr>
<td>TS Series Training Manual (this manual)</td>
<td>This manual provides detailed explanations of the screen creation process with examples using V-SFT version 5.</td>
<td>1203NE</td>
</tr>
<tr>
<td>TS Series Connection Manual</td>
<td>This manual provides detailed explanations of the connections between the TS Series unit and each type of controller as well as communication settings.</td>
<td>2203NE</td>
</tr>
<tr>
<td>TS Series Hardware Specifications</td>
<td>This manual explains the hardware specifications and operating methods of the TS Series unit.</td>
<td>2022NE</td>
</tr>
<tr>
<td>V8 Series Reference Manual</td>
<td>This manual explains the functions and operating methods of the V8 Series.</td>
<td>1055NE</td>
</tr>
<tr>
<td>V8 Series Reference: Additional Functions</td>
<td>This manual explains the V8 Series functions and operating methods added to V-SFT version 5.1.0.0 and later.</td>
<td>1060NE</td>
</tr>
<tr>
<td>V Series Macro Reference</td>
<td>This reference provides an overview of the macros available in V-SFT version 5 as well as detailed explanations of macro editor operations and macro commands.</td>
<td>1056NE</td>
</tr>
<tr>
<td>V8 Series Operation Manual</td>
<td>This manual provides detailed explanations of information related to operating V-SFT version 5, such as software composition, editing procedures, and limitations.</td>
<td>1058NE</td>
</tr>
</tbody>
</table>

For more information on each type of controller (PLC, temperature control, etc.), refer to the manufacturer’s instruction manual for the corresponding controller.

Notes:
1. No part of this manual may be reproduced without prior permission.
2. The contents of this manual may change without prior notice.
3. Windows and Excel are registered trademarks of Microsoft Corporation in the United States and other countries.
4. All other company names or product names are trademarks or registered trademarks of their respective holders.
5. While the utmost care has been taken in the production of this manual, please contact your local distributor regarding any doubts on the accuracy of explanations.
Notes on Safety

In this manual, you will find various notes categorized under the following levels with the signal words "DANGER," and "CAUTION."

- **DANGER** Indicates an imminently hazardous situation which, if not avoided, will result in death or serious injury.
- **CAUTION** Indicates a potentially hazardous situation which, if not avoided, may result in minor or moderate injury and could cause property damage.

Note that there is a possibility that items listed with **CAUTION** may have serious ramifications.

- **DANGER**
  - Never use the input and output signals of the TS Series unit for operations that may threaten human life, cause damage to the system, or as emergency switches. Please design the system so that it can withstand touch switch malfunctions. Touch switch malfunctions may result in machine accidents or damage.
  - Turn off the power supply when you set up the unit, connect new cables, or perform maintenance or inspections. Failure to do so could cause electric shock or damage to the unit.
  - Never touch any terminals while the power is on. Otherwise, electric shock may occur.
  - The liquid crystal in the LCD panel is a hazardous substance. If the LCD panel is damaged, avoid ingesting any leaking liquid crystal. If any liquid crystal spills onto your skin or clothing, use soap to wash it off thoroughly.
  - Never disassemble, recharge, deform by pressure, short-circuit, or reverse the polarity of lithium batteries, and never dispose of lithium batteries in fire. Failure to follow these conditions may lead to explosion or ignition.
  - Never use lithium batteries that are deformed, leaking, or exhibit any other abnormalities. Failure to follow these conditions may lead to explosion or ignition.
Check the appearance of the TS Series unit after unpacking. Do not use the unit if any damage or deformation is found. Using the unit in such a state may lead to fire, damage, or malfunction.

Please consult your local distributor before using this product in facilities or systems related to nuclear energy, aerospace, medical, traffic equipment, or mobile installations.

Operate (and store) the TS Series unit under the environmental conditions indicated in the general specifications of this manual and related manuals. Failure to do so could cause fire, malfunction, physical damage or deterioration.

Understand the following environmental limits for use and storage of TS Series units. Failure to follow these conditions may result in fire or damage to the unit.

- Avoid locations where there is a possibility that water, corrosive gas, flammable gas, solvents, grinding fluids, or cutting oil may come into contact with the unit.
- Avoid high temperature, high humidity, and outside weather conditions, such as wind, rain, or direct sunlight.
- Avoid locations where excessive dust, salt, or metallic particles are present.
- Avoid installing the unit in a location where vibrations or physical shocks may be transmitted.

Equipment must be correctly mounted so that the main terminal of the TS Series unit cannot be touched inadvertently. Failure to do so may result in electric shock or accidents.

Periodically check that the terminal screws on the power supply terminal block and mounting nuts are firmly tightened. Using the unit with loose screws may result in fire or malfunction.

Tighten the terminal screws on the TS Series power supply terminal block to an equal torque of 0.5 to 0.6 N•m (5 to 6 kgf•cm). Failure to tighten these screws properly may result in fire, malfunction, or damage to the system.

The TS Series features a glass screen. Do not drop or impart physical shocks to the unit. Such handling will damage the unit.

Connect the cables correctly to the terminals of the TS Series unit in accordance with the specified voltage and wattage. Failure to supply the correct voltage or wattage, or improper cable connection may cause fire, malfunction, or damage to the unit.

Always ground the TS Series unit. Ground the FG terminal of the TS Series unit with an independent D class grounding (ground resistance of 100 Ω or less). Failure to do so may result in electric shock or fire.

Prevent any conductive particles from entering into the TS Series unit. Failure to do so may lead to fire, damage, or malfunction.

Do not attempt to repair the TS Series unit at your site. Contact Hakko Electronics Co., Ltd. or the designated contractor for repairs.

Do not attempt to repair, disassemble, or modify the TS Series unit. Hakko Electronics Co., Ltd. is not responsible for any damages resulting from repairs, disassembly, or modification of TS Series units performed by unauthorized personnel.

Do not use sharp-pointed tools to press touch switches. Doing so may damage the screen.

Only personnel who possess the required knowledge and technical skills are authorized to set up the unit, connect the cables, and perform maintenance and inspections.

Lithium batteries contain combustible material such as lithium and organic solvents. Mishandling may cause heat, explosion, or ignition resulting in fire or injury. Read the related manuals carefully and handle lithium batteries correctly as instructed.

Do not press two or more positions on the screen at the same time. If two or more positions are pressed at the same time, the switch located between the pressed positions will be activated.

Take sufficient safety precautions during operations such as changing settings during running, forced output, start, and stop. Operating errors may cause unexpected machine motions, resulting in machine accidents or damage.

In facilities where TS Series unit failure could lead to accidents that threaten human life or result in other serious damage, make sure that such facilities are equipped with adequate safeguards.

TS Series units must be disposed of as industrial waste.

Before touching the TS Series unit, discharge any static electricity from your body by touching grounded metal. Excessive static electricity may cause malfunction or damage to the unit.
[General Notes]

- Never bundle control cables and communication cables with high-voltage and large-current carrying cables such as power supply cables. Keep these cables at least 200 mm away from high-voltage and large-current carrying cables. Otherwise, malfunction may occur due to noise.
- When using the TS Series unit in an environment where a source of high-frequency noise is present, it is recommended that the FG shielded cable (communication cable) be grounded at both ends. However, the cable may be grounded only at one end if necessary due to unstable communication conditions or for other reasons.
- Plug connectors and sockets of the TS Series unit in the correct orientation. Otherwise, malfunction or damage may occur.
- Do not use thinners for cleaning because it may discolor the surface of the TS Series unit. Use a commercially available alcohol-based cleaner instead.
- If a “data receive error” occurs when the TS Series unit and the counterpart unit (PLC, temperature controller, etc.) are started at the same time, read the instruction manual for the counterpart unit and handle the error accordingly.
- Avoid discharging static electricity on the mounting panel of the TS Series unit. Static charge can cause malfunctions due to noise.
- Avoid prolonged display of any fixed pattern. An afterimage may remain due to the characteristics of the liquid crystal display. If a prolonged display of a fixed pattern is expected, use the backlight’s auto OFF function.

[Notes on the LCD Screen]

Note that the following conditions may occur under normal circumstances.

- The response time, brightness, and colors of the TS Series unit may be affected by the ambient temperature.
- Tiny spots (dark or luminescent) may appear on the display due to liquid crystal characteristics.
- Each unit varies slightly with respect to brightness and colors.
## Contents

Preface

Notes on Safety

1. Creating New Files ................................................................. 1-1
2. Creating Switches and Lamps .............................................. 2-1
3. Creating Overlaps ............................................................... 3-1
4. Entry Screens ................................................................. 4-1
5. Alarm Screens ............................................................... 5-1
6. Trend Screen (Trend Sampling) ........................................ 6-1
7. Screen Data Transfer ....................................................... 7-1
1. Creating New Files

This chapter explains how to create new files and the initial screen displayed when the unit first starts up after turning on the power.

Contents

Screen Example .................................................................................................................. page 1-1
Screen Creation ................................................................................................................ page 1-2
  1. Creating a New File ............................................................................................... page 1-2
  2. Changing the Background Color ........................................................................ page 1-5
  3. Drawing Graphics ................................................................................................. page 1-7
  4. Moving and Aligning Parts ................................................................................ page 1-13
  5. Saving Files ........................................................................................................ page 1-16
Unit Operation ............................................................................................................ page 1-17
Error Display .............................................................................................................. page 1-17

Screen Example

The drawing tools are used to draw graphics, place text, and paste image files (JPEG, bitmap).
1. Creating New Files

1. Creating a New File

1. Start V-SFT-5.
2. Click [File] → [New] or click the [New File] icon.

3. Configure the following settings in the [Edit Model Selection] dialog box and click [OK].
   Create the example screen in this manual with the following settings.
   - Edit Model : TS1100
   - i Series : Selected
   - Color : 32K-Color

4. Configure the PLC type and TS connection port in the [PLC1 Connection Device Selection] dialog box and click [OK].
   Create the example screen in this manual with the following settings.
   - Device connected : PLC
   - Maker : MITSUBISHI ELECTRIC
   - Series : QnH (Q) series link
   - Connect to : COM2
5. Configure the communication parameters in the [Device Connection Setting] window. For more information on settings in the [Device Connection Setting] window, refer to the “TS Series Connection Manual.”

6. Click the [Close] button to close the [Device Connection Setting] window. The [Screen [0] Edit] window is displayed.
1. Creating New Files

7. Click [System Setting] → [Font Setting]. The [Font Setting] dialog box is displayed.

8. Set the font using the [Setting] button. Click the [OK] button to close the dialog box. For more information on settings in the [Font Setting] dialog box, refer to the “V8 Series Reference Manual.”
2. Changing the Background Color

This section explains how to change the background color.

1. Click [Screen Setting] → [Screen Setting].
   The [Screen Setting] dialog box is displayed.

2. Click the [Back Color] button on the [Main] tab. A drop-down list for color selection is displayed.
   Select the desired background color.

3. The selected color is displayed on the icon and the background changes to this color.
Click [Custom Color] to select a color that is not shown on the drop-down list. The [Custom Color] dialog box is displayed.

Select the desired background color.
3. Drawing Graphics

This section explains how to use the drawing tools to create text and draw graphics.

3.1 Draw Toolbar

The icons on the [Draw] toolbar are shown below. Click the → symbol on the right of each icon to change the properties of each icon’s function.
3.2 Creating a Rectangle

1. Click the [Rectangle] icon on the [Draw] toolbar. The [Rectangle] icon becomes depressed and the mouse cursor changes to a cross-shaped cursor.

2. Drag from the start point to the end point on screen using the mouse. This draws a rectangle.
3. Set the color and frame type in the item dialog box.
3.3 Creating Text


2. Drag from the start point to the end point on screen using the mouse. The specified area and a blinking cursor are displayed on screen.

3. Enter text.

4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box. Change the text color and text size properties.

Windows fonts on the computer can also be set in addition to the standard bitmap fonts. Windows fonts on the computer can also be set.

Windows Fonts

The use of Windows fonts enables text size settings from 6 to 999 points and results in smoother display.

12P Arial
14P Arial
20P Arial
12P N9imsun
14P N9imsun
20P N5imsun

However, note that a common font should be used when editing on multiple computers because the types of Windows fonts can vary between computers. A warning message is displayed if attempting to use a Windows font that is not present on the computer. In this case, editing cannot be performed unless the missing font is substituted with another Windows font or the missing font is installed.
3.4 Pasting JPEG/Bitmap Files

This section explains how to load JPEG or bitmap files of company logos or machine image data onto the screen as pattern data.

1. Click [Tool] → [Paste Image File] → [Pattern]. The [Open Image File] dialog box is displayed.

2. Select the file to load and click [Open]. The loaded image is displayed.
3. Click the [Place] button to place the image on the screen.

The loaded image is registered to [Registration Item] → [Pattern]. The image can be used on other screens by clicking the [Pattern] icon ( ) on the [Draw] toolbar and selecting the image for placement.

Loading the same image multiple times results in multiple registrations and increases the screen data size. Delete any unnecessary patterns.
4. Moving and Aligning Parts

This section explains how to move parts, change item size, and align multiple parts.

4.1 Moving Parts

1. Click on the part. Handles are displayed around the part.
2. With the mouse cursor displaying a cross-shaped mark, drag the part to another position.

![Moving Parts Diagram]

The part position can also be set using [Start X] and [Start Y] on the [Coordinates] tab in the item dialog box.

4.2 Enlarging and Reducing Part Size

1. Click on the part. Handles are displayed around the part.
2. Place the mouse cursor over a handle. The mouse cursor changes to a ↔ mark.
3. Drag the handle with the mouse cursor displayed as ↔.

![Enlarging and Reducing Part Size Diagram]
4.3 Aligning Parts and Matching Size

This section explains how to align the positions and match the sizes of multiple parts at once.

1. Select the parts for alignment. Handles are displayed around the parts.
2. Hold down the [Ctrl] key and click the reference part. The handle color of this part changes and the part is specified as the reference part.
3. Use the [Layout] icons or the [Edit] menu → [Arrangement (Equal)] submenu or [Put All in Same Size] submenu to align the positions or match the sizes of parts.

Example: Left justification
1. Creating New Files

Grid Settings/Center Line Display

Use [Center Line Display] and [Grid Display] to display center lines and grid lines of reference on screen to assist with item placement. These lines are only displayed in the V-SFT software and not on the unit.

Display the center lines by clicking [View] → [Customize] → [Center Line Display].

Display grid line settings by clicking [View] → [Grid] → [Grid Display] and configure grid lines by clicking [View] → [Grid] → [Grid Setting].
5. Saving Files

5.1 Saving as a New File

1. Click [File] → [Save As]. The [Select the image data to be saved.] dialog box is displayed.

![Select the image data to be saved dialog box]

2. Enter the desired filename and click [Save].

![Save file dialog box]

File creation is complete. Screen data may now be transferred to the unit.
1. Creating New Files

Unit Operation

Screen data is displayed when the TS Series unit and PLC are connected correctly. Check that the unit operates properly.

1. Error Display

1.1 Communication Error - Timeout

Communication is not being performed correctly due to any of the following reasons.

- The model select for screen data in the [Device Connection Setting] window differs from the actual connected model.
- The communication parameters of the TS Series unit and the PLC do not match.
- The communication cable is not connected correctly or disconnected.

1.2 Screen No. Error

Check the value of the screen number command specified in the read area (n + 2).
The TS Series unit displays screens by looking at the memory value of the screen number command when communication starts. The “Screen No. Error” message is displayed if this value is set to a screen number that does not exist.

For the screen data in this manual, the [Read Area] value is “D0000” so the screen number command memory is “D0002”. For data where screen numbers 0 to 5 have been created:

- $D0002 = 0$ to $5 \rightarrow$ Display correctly
- $D0002 = 6$ to $9999 \rightarrow$ Screen No. Error

### Read Area

The [Read Area] and [Write Area] settings can be accessed by clicking [System Setting] → [Device Connection Setting].

The read area is the memory address where the PLC issues display or operation commands to the TS Series unit. Three words of consecutive memory addresses are secured for this purpose.

#### Read Area Description Setting Example

<table>
<thead>
<tr>
<th>n</th>
<th>Description</th>
<th>Setting Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>n + 1</td>
<td>Screen status command</td>
<td>D1</td>
</tr>
<tr>
<td>n + 2</td>
<td>Screen number command</td>
<td>D2</td>
</tr>
</tbody>
</table>

### Write Area

This memory address is for outputting the screen status from the TS Series unit to the PLC. Three words of consecutive memory addresses are secured for this purpose.

#### Write Area Description Setting Example

<table>
<thead>
<tr>
<th>n</th>
<th>Description</th>
<th>Setting Example</th>
</tr>
</thead>
<tbody>
<tr>
<td>n + 1</td>
<td>Screen status</td>
<td>D51</td>
</tr>
<tr>
<td>n + 2</td>
<td>Displayed screen number</td>
<td>D52</td>
</tr>
</tbody>
</table>
2. Creating Switches and Lamps

This chapter explains how to create screens that contain switches and lamps.

**Contents**

- Screen Example.................................................................................................................. page 2-1
- Screen Creation................................................................................................................ .. page 2-2
  - 1. Editing Screens........................................................................................................ page 2-13
    - 2. Procedure for Changing Parts............................................................................ page 2-13
  - Confirming Unit Operation........................................................................................ page 2-19
    - 1. Memory Addresses............................................................................................ page 2-19
    - 2. Unit Operation................................................................................................. page 2-19

**Screen Example**

Create the following example screen that uses switch output to turn lamps on and off and switches to another screen using a switch.
2. Creating Switches and Lamps

Screen Creation

1. Editing Screens

1.1 Creating a New Screen


1.2 Changing the Background Color

Change the background color of the screen by clicking [Screen Setting] → [Screen Setting]. For more information, refer to “Changing the Background Color” on page 1-5.
1.3 Placing Switches

1. Click [Parts] → [Parts List]. The [Parts List] window is displayed.

2. Select [Switch], [Real], and [#1 [Square1]].

3. Select a switch and drag it onto the screen. This places the switch on the screen.
2. Creating Switches and Lamps

In addition to the [Parts List], the following four methods are available for placing parts.
1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1. Parts icons

2. [Parts] menu

3. [Catalog] dialog box

4. Wizard ([Parts] menu)

5. Configure each setting in the switch’s item dialog box.
   • [Main] tab
     Set the bit memory address for output and select a setting for [Function].

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Memory</td>
<td>Set the bit memory address to output when the switch is pressed.</td>
<td>Selected M100</td>
</tr>
<tr>
<td>Multi-output</td>
<td>Select this checkbox to perform a single output action with respect to multiple memory addresses.</td>
<td>Deselected</td>
</tr>
</tbody>
</table>
### 2. Creating Switches and Lamps

#### Output Action
Set the write operation to perform with respect to the output memory address.

<table>
<thead>
<tr>
<th>Switch Operation</th>
<th>Output Processing</th>
</tr>
</thead>
<tbody>
<tr>
<td>Set</td>
<td>The specified bit memory address is set to “ON”.</td>
</tr>
<tr>
<td>Reset</td>
<td>The specified bit memory address is reset to “OFF”.</td>
</tr>
<tr>
<td>Momentary</td>
<td>The specified bit memory address is set to “ON” while the switch is depressed.</td>
</tr>
<tr>
<td>Alternate</td>
<td>The specified bit memory address is alternately set (ON) and reset (OFF) each time the switch is pressed.</td>
</tr>
</tbody>
</table>

#### Lamp Memory
Change the display of the switch area.

- **Deselected:** Pressing the switch turns on the lamp in the switch. Releasing your finger from the switch turns the lamp off.
- **Selected:** Set the memory address for the lamp display using [Memory Designation] and [Input Type].

#### Connect Output Memory and Lamp Memory
Select this checkbox to use the same memory address for output memory and lamp memory.

#### Function
Set the function of the switch, or in order words, how the switch should work when it is pressed. Functions that are frequently used include “Screen”, “Overlap Display”, and “Multi-Overlap Display”.*1

*1 For more information on functions, refer to the “V8 Series Reference Manual.”

---

**Table:**

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Action</td>
<td>Set the write operation to perform with respect to the output memory address.</td>
<td>Momentary</td>
</tr>
<tr>
<td>Lamp Memory</td>
<td>Change the display of the switch area.</td>
<td>-</td>
</tr>
<tr>
<td>Connect Output Memory and Lamp Memory</td>
<td>Select this checkbox to use the same memory address for output memory and lamp memory.</td>
<td>Selected</td>
</tr>
<tr>
<td>Function</td>
<td>Set the function of the switch, or in order words, how the switch should work when it is pressed. Functions that are frequently used include “Screen”, “Overlap Display”, and “Multi-Overlap Display”.*1</td>
<td>No Function</td>
</tr>
</tbody>
</table>
2. Creating Switches and Lamps

- **Text**
  Set the text displayed on the switch.

If the switch displays different text in the ON and OFF states, register the text to display in each state on the [ON] and [OFF] tabs.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFF, ON to P128 Pattern No.</td>
<td>Register the text to be displayed on the switch.</td>
<td>M100</td>
</tr>
<tr>
<td>Color Property</td>
<td>Set the text color, properties, and text size.</td>
<td></td>
</tr>
<tr>
<td>Enlarge</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Point</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Rotation + Direction</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Windows Font</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

- Changes to the settings on the [Interlock], [Macro], [Style], [Delay], [Detail], and [Display Setting] tabs are not covered in this section.
1.4 Creating Multiple Copies of Switches

This section explains how to copy a switch multiple times.

1. Select a switch. Handles are displayed around the switch.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon. The [Multi Copy] dialog box is displayed.

3. Set the options as shown below and click [OK]. This copies the switch multiple times.
4. Click [View] → [Customize] → [Memory Display]. Memory addresses are displayed at the lower left on each switch.

5. Change the switch text and output action to the following.

This completes the switch creation process.
1.5 Placing Lamps

1. Click [Parts] → [Parts List]. The [Parts List] window is displayed.
2. Select [Lamp], [Real], and [#0 [Circle1]].

3. Select a lamp and drag it onto the screen. This places the lamp on the screen.

4. Configure each setting in the lamp’s item dialog box.
   • [Main] tab
     Set the memory address for the lamp.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Lamp Memory</td>
<td>The display of the lamp area can be changed. Set the memory address for the lamp display using [Memory Designation] and [Input Type].</td>
<td>M100</td>
</tr>
<tr>
<td>Function</td>
<td>Set the lamp’s function. Normally select [No Function].</td>
<td>No Function</td>
</tr>
</tbody>
</table>
2. Creating Switches and Lamps

• [Text] tab
  Set the text displayed on the lamp.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>OFF, ON to P128 Pattern No.</td>
<td>Register the text to be displayed on the lamp.</td>
<td>M100</td>
</tr>
<tr>
<td></td>
<td>Color Property Enlarge Point Rotation + Direction Windows Font</td>
<td>-</td>
</tr>
<tr>
<td></td>
<td>Set the text color, properties, and text size.</td>
<td></td>
</tr>
</tbody>
</table>

- Changes to the settings on the [Style], [Detail], and [Display Setting] tabs are not covered in this section.
1.6 Creating Multiple Copies of Lamps

Create multiple copies of lamps using the same procedure for multiple copies of switches.

1. Select the lamp. Handles are displayed around the lamp.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon. The [Multi Copy] dialog box is displayed.

3. Set the options as shown below and click [OK]. This copies the lamp multiple times.
4. Change the text displayed on each lamp.

This completes the lamp creation process.
2. Procedure for Changing Parts

Perform the following procedure to change the design or color of parts placed on the screen.

2.1 Changing Parts

1. Select the part for changing to display its item dialog box.

2. Click [Style] → [Change Part]. The [Change Part] window is displayed.
2. Creating Switches and Lamps

3. Select the part using [Change Part Color] and [Part Type Change].

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
</tr>
</thead>
<tbody>
<tr>
<td>□ Maintain Size</td>
<td>Deselected: Change to the default size. Selected: Maintain the size prior to changing.</td>
</tr>
<tr>
<td>Pattern Change</td>
<td>The pattern image of OFF, ON, and patterns up to P128 can be checked.</td>
</tr>
<tr>
<td>Change Part Color</td>
<td>Change the color.</td>
</tr>
<tr>
<td>Part Type Change</td>
<td>Change the part type.</td>
</tr>
<tr>
<td></td>
<td>Real/Sign/3D</td>
</tr>
<tr>
<td></td>
<td>Circle/Square/Plant/Icon etc.</td>
</tr>
</tbody>
</table>

4. Select the part properties for changing and click [Select] to change the lamp on the screen.
2. Creating Switches and Lamps

2.2 Changing the Color of Parts

1. Select the part for changing to display its item dialog box.

2. Select the pattern (OFF/ON/P3 or higher) whose color is to be changed on the [Style] tab and click [Customize].

3. Select an image and color in the [Change the image] window.
Different color settings for OFF and ON can be configured by changing the color in the [Change the image] window.

<table>
<thead>
<tr>
<th></th>
<th>OFF</th>
<th>ON</th>
</tr>
</thead>
<tbody>
<tr>
<td>Before change</td>
<td>M1DD</td>
<td>M1DD</td>
</tr>
<tr>
<td>After change</td>
<td>M1DD</td>
<td>M1DD</td>
</tr>
</tbody>
</table>
2.3 Placing Text

This section explains how to place the screen title and other text elements.

◆ Creating Text
1. Click the [Text] icon on the [Draw] toolbar. A cross-shaped cursor is displayed.
2. Click on the screen. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box. Change the text color and text size properties.
2.4 Creating a Switch for Changing to Another Screen

This section explains how to place a switch that changes between screen 0 and screen 1 when pressed.

1. Place a switch.
2. Set [Function] to “Screen” in the switch’s item dialog box and set [Screen No.] to the number of the destination screen.

3. Adjust the switch color and position.

This completes the screen creation process. The next section covers confirming screen operation on the TS Series unit.
2. Creating Switches and Lamps

Confirming Unit Operation

1. Memory Addresses

The memory addresses used in this example are listed below.

<table>
<thead>
<tr>
<th>Memory Address</th>
<th>Memory Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>M100</td>
<td>Switch output memory (momentary), lamp memory</td>
</tr>
<tr>
<td>M101</td>
<td>Switch output memory (alternate), lamp memory</td>
</tr>
<tr>
<td>M102</td>
<td>Switch output memory (set/reset), lamp memory</td>
</tr>
</tbody>
</table>

2. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

2.1 Switching Screens

1. Screen 0 is displayed initially.
   (Refer to the next page if a different screen or “Screen No. Error” is displayed.)

2. Press [Screen1] at the upper right of the screen. The screen changes to display screen 1.
2. Creating Switches and Lamps

Changing Screens Using PLC Commands (External Commands)

The [Read Area] and [Write Area] settings, accessed by clicking [System Setting] → [Device Connection Setting], are used for this purpose. “D0002” is used for the screen number command memory in this manual.

Setting “D0002” to the screen number will allow the display to change. Note that the screen number of the currently displayed screen is stored using “D0052” in the [Write Area].

The screen number to display when the unit is powered on is also determined by “D0002”. The “Screen No. Error” message is displayed if a screen number that does not exist is set.

For more information on the [Read Area] and [Write Area], refer to page 1-17.
2. Creating Switches and Lamps

2.2 Switch Output and Lamp Display

♦ Momentary Switch
The output memory address is set to “ON” while the switch is depressed.

1. Press the M100 (momentary) switch. The M100 lamp turns on.

2. Releasing your finger from the switch turns the M100 lamp off.
2. Creating Switches and Lamps

♦ Alternate Switch
The specified bit memory address is alternately set (ON) and reset (OFF) each time the switch is pressed.


2. The M101 lamp stays on even after releasing your finger from the switch.


The ON/OFF state of the lamp changes each time the switch is pressed.
Set/Reset Switch
The specified bit is set to “ON” or “OFF”.

1. Press the M102 (set) switch. The M102 lamp turns on.

2. The M102 lamp stays on even after releasing your finger from the switch.

3. Press the M102 (reset) switch. The M102 lamp turns off.
3. Creating Overlaps

Windows can be temporarily overlaid on the displayed screen when necessary. These types of windows are referred to as “overlaps”.
A maximum of four overlaps can be displayed at once on the screen.

Overlaps that are frequently used include normal overlaps, which can only be displayed on the screen on which they are created, and multi-overlaps registered to the overlap library that can be used across several screens.

- Normal Overlap

- Multi-overlap
Add a multi-overlap to screen 1, which was created with switches and lamps.
1. Editing the Overlap Library

This section explains how to create overlaps.

Almost all items including switches, lamps, and alarms can be placed on overlaps.

1.1 Placing Overlaps

1. Click [Registration Item] → [Overlap Library]. The [Overlap Library] dialog box is displayed.

2. Select a registration number and click the [OK] button. The [Overlap Library Edit] window is displayed.

3. Click [Parts] → [Overlap] → [Normal Overlap] to place an overlap.
4. Configure settings in the item dialog box.
   • [Main] tab

   ![Main Tab Image]

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Button</td>
<td>Select this checkbox to add a switch function (move/dismiss) to the upper left corner of the overlap area. For more information on the operation of this switch, refer to “1.2 Overlap System Button Function” (page 3-15).</td>
<td>Selected</td>
</tr>
</tbody>
</table>

   • [Style] tab

   ![Style Tab Image]

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Set the area color.</td>
<td>-</td>
</tr>
<tr>
<td>Frame, Area</td>
<td></td>
<td>-</td>
</tr>
<tr>
<td>Change Part</td>
<td>Change the part used for the overlap.</td>
<td>-</td>
</tr>
</tbody>
</table>

   • [Detail] tab
   Settings on this tab do not require configuration.

   • [Coordinates] tab
   Set the placement position and size of the overlap.
1.2 Placing Text

This section explains how to place text on the overlap.

1. Click the [Text] icon ( ). A cross-shaped cursor is displayed.
2. Click on the overlap. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box. Change the text color and text size properties.

The size of the overlap can also be changed by selecting the overlap and dragging the displayed handles.
1.3 Placing Switches

This section explains how to create a switch for hiding the overlap.

1. Click [Parts] [Parts List]. The [Parts List] window is displayed.
2. Select [Switch], [Real], and [#18 [Icon10]].

3. Select a switch and drag it onto the overlap. This places the switch on the overlap.
4. Set the [Function] option in the switch’s item dialog box.

Function: Standard, Overlap Display
Overlap ID: 0
Action: OFF

The completes the overlap editing process.

Match the overlap ID to the ID of the screen’s overlap icon. (For more information on the overlap icon, refer to page 3-12.)

Edit items on the overlap by clicking [Overlap Editing] → [No. 0] on the right-click menu. This allows multiple items to be selected by dragging with the mouse.

The completes the overlap editing process.
2. Editing Screens

This section explains how to register a multi-overlap icon and a switch for displaying a multi-overlap.

![](image)

2.1 Placing the Switch


![](image)

2. Click [Parts] [Parts List]. The [Parts List] window is displayed.
3. Select [Switch], [Real], and [#1 [Square1]].

4. Select the switch and drag it onto the screen. This places the switch on the screen.

In addition to the [Parts List], the following four methods are available for placing parts.

1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1. Parts icons

2. [Parts] menu

3. [Catalog] dialog box

4. Wizard ([Parts] menu)
5. Set the [Function] option in the switch's item dialog box.
   - [Main] tab

   ![Image of switch item dialog box]

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Output Memory</td>
<td>Set the bit memory address to output when the switch is pressed.</td>
<td>Deselected</td>
</tr>
<tr>
<td>Lamp Memory</td>
<td>Change the display of the switch area.</td>
<td>Deselected</td>
</tr>
<tr>
<td></td>
<td>Deselected: Pressing the switch turns on the lamp in the switch. Releasing your finger from the switch turns the lamp off.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Selected: Set the memory address for the lamp display using [Memory Designation] and [Input Type].</td>
<td></td>
</tr>
<tr>
<td>Function</td>
<td>Select the function of the switch, or in other words, how the switch should work when it is pressed. Functions that are frequently used include &quot;Screen&quot;, &quot;Overlap Display&quot;, and &quot;Multi-Overlap Display&quot;.*1</td>
<td>Multi-Overlap Display</td>
</tr>
<tr>
<td>Overlap ID</td>
<td>Set the overlap ID. Setting value: 0 to 2</td>
<td>0</td>
</tr>
<tr>
<td>Overlap Library No.</td>
<td>Set the overlap library number. Setting value: 0 to 9999</td>
<td>0</td>
</tr>
<tr>
<td>Display Position</td>
<td>Set the [X Coordinate] and [Y Coordinate] values for the display position of the overlap. Specify with Mouse: Specify the coordinates by clicking with the mouse.*2</td>
<td>Selected X120 Y125</td>
</tr>
</tbody>
</table>

*1 The settings for normal overlap display are:
- [Main] tab
- Function: Overlap Display
- Action: ON

![Image of switch item dialog box with highlighted Overlap ID and Display Position]
*2 Mouse specification method
Click the [Specify with Mouse] button. A cross-shaped cursor and a rectangle the size of the overlap are displayed.

Click on a position where the rectangle does not protrude outside the screen. The \( \text{OVLP} \) mark that shows the display position of the multi-overlap moves to the clicked position.

- [Text] tab
  Register the text displayed on the switch.

This completes the switch creation process.
2.2 Registering an Overlap Icon

1. Click [Parts] → [Overlap] → [Multi-Overlap].

2. Click on the screen to place the multi-overlap icon.

3. Configure settings in the item dialog box.
   • [Main] tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Overlap ID</td>
<td>A maximum of three overlaps can be displayed at once. Set the area of IDs 0 to 2 in which to display the overlap registered in the overlap library. Setting value: 0 to 2</td>
<td>0</td>
</tr>
<tr>
<td>Designate Internal, External</td>
<td>Display the overlap using the switch function. Specify the overlap library number in a memory address and show or hide the overlap according to the bit in the read area or command memory.</td>
<td>Internal</td>
</tr>
</tbody>
</table>


<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Info Output Memory</td>
<td>Stores the currently displayed overlap library number. This memory address stores “-1” when the overlap display is hidden.</td>
<td>-</td>
</tr>
<tr>
<td>Overlap Library No.</td>
<td>This option is valid when [Designate] is set to “External”. This memory address specifies the overlap library number.</td>
<td>-</td>
</tr>
<tr>
<td>□ Coordinate Designation</td>
<td>This option is valid when [Designate] is set to “External”. Select this checkbox to set the display position of the overlap (X and Y coordinates).</td>
<td>-</td>
</tr>
</tbody>
</table>

- [Detail] tab
  Settings on this tab do not require changing.

This completes the screen creation process. The next section covers confirming screen operation on the TS Series unit.
3. Creating Overlaps

Confirming Unit Operation

1. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

1.1 Showing and Hiding Multi-overlaps

1. Display screen 1.

2. Press the [OVLP] switch. The overlap is shown.

3. Press the [CLOSE] switch. The overlap is hidden.
1.2 Overlap System Button Function

A system button function can be added to overlaps. This function can perform the following two operations.

- Overlap movement
- Overlap dismissal

Movement and dismissal of overlaps is only available when the [System Button] checkbox is selected in the overlap settings.

1. Press the [OVLP] switch to display the multi-overlap.

2. Press the upper left corner of the overlap. The periphery of the overlap starts flashing.
3. While the periphery of the overlap is flashing, press the position to move the overlap. The overlap moves to the specified position.

4. Double-tap the upper left corner of the overlap to dismiss it.
4. Entry Screens

This chapter explains how to create a keypad entry screen. As keypads are usually not permanently displayed on screens, here we will create a screen that displays a keypad only when entry is required.

- Normal: Keypad OFF

- Entry: Keypad displayed

![Entry Screen](image)

**Contents**

- Screen Example........................................................................................................... page 4-2
- Screen Creation......................................................................................................... page 4-3
  1. Editing Screens .................................................................................................... page 4-3
  2. Overlap Library .................................................................................................. page 4-14
- Confirming Unit Operation .................................................................................... page 4-19
  1. Memory Addresses............................................................................................ page 4-19
  2. Unit Operation ................................................................................................... page 4-19
In this section, create a screen for entering values into parts “D100” through “D115”.

**Screen Example**

![Entry Screen](image)

**Keypad display**

**Entry**

![Entry Screen](image)
Screen Creation

1. Editing Screens

Screen editing involves registration of numerical data and character displays targeted for writing as well as multi-overlaps.

1.1 Placing Numerical Data Displays and Registering Keypads

1. Click [Parts] → [Parts List]. The [Parts List] window is displayed.
2. Select [Entry], [Real #0 NUM.Display].
3. Select a numerical data display part and drag it onto the screen. This places the numerical data display on the screen.

4. Configure each setting in the numerical data display’s item dialog box.
   - [Main] tab
     Set the memory address for writing and select a setting for [Function].

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>Set the memory address for writing.</td>
<td>D100</td>
</tr>
<tr>
<td>Offset Value Designation Memory</td>
<td>Select this checkbox to specify an offset. Not used in this section. For more information, refer to the “V8 Series Reference Manual.”</td>
<td>Deselected</td>
</tr>
<tr>
<td>Data Length</td>
<td>Set the data length of the memory address for writing. Setting value: 1-Word/2-Word</td>
<td>1-Word</td>
</tr>
</tbody>
</table>
### Screen Creation

#### 4. Entry Screens

**Registration method**

Setting [Overlap Library No.] to “1” and clicking the [Register] button displays the [Change Part] window. Select the design and color and then click the [Select] button.

A keypad is registered to the specified overlap library number. For more information on the registered details, refer to page 4-14.

If the specified overlap library number is already registered, the following confirmation message is displayed. Select [Yes] to overwrite the overlap library number or select [No] to register the keypad to another overlap library number.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digits</td>
<td>Set the number of digits used by the memory address for writing. Setting value: 1 to 32</td>
<td>5</td>
</tr>
<tr>
<td>Decimal Point</td>
<td>Select whether to include a decimal point. Setting value: 0: No decimal point 1 to 10: Insert decimal point (at corresponding 1st to 10th decimal place)</td>
<td>0</td>
</tr>
<tr>
<td>Display Type</td>
<td>Set the format of numbers to be displayed on the screen.</td>
<td>DEC (with sign +-)</td>
</tr>
<tr>
<td>Input Type</td>
<td>Set the format for reading values from memory.</td>
<td>DEC</td>
</tr>
<tr>
<td>☐ Zero Suppress</td>
<td>Select this checkbox to enable zero suppression.</td>
<td>Selected Flush Right</td>
</tr>
<tr>
<td>Function</td>
<td>Set the numerical data display function.</td>
<td>Entry Target</td>
</tr>
<tr>
<td>Order INC</td>
<td>Set the order in which the cursor moves when multiple entry targets are placed on the screen.</td>
<td>0</td>
</tr>
<tr>
<td>☐ With Entry Key</td>
<td>Function: Entry Target (enabled when selected) Select this checkbox to add the entry key call function.</td>
<td>Selected</td>
</tr>
<tr>
<td>Overlap ID</td>
<td>Set the overlap ID to be used for showing the entry keys. Setting value: 0 to 2</td>
<td>0</td>
</tr>
<tr>
<td>Overlap Library No. Register button</td>
<td>Set the overlap library number for registering the entry keys. Select the desired keypad by pressing the [Register] button and register the keypad to the overlap library. If the keypad is already registered to the overlap library, simply specify the overlap library number. Setting value: 0 to 9999</td>
<td>1</td>
</tr>
<tr>
<td>☐ Display Position X Coordinate Y Coordinate Specify with Mouse button</td>
<td>Set the [X Coordinate] and [Y Coordinate] values for the display position of the overlap. [Specify with Mouse] button: Specify the coordinates by clicking with the mouse.</td>
<td>Selected X Coordinate: 240 Y Coordinate: 145</td>
</tr>
</tbody>
</table>

*1 Registration method

Setting [Overlap Library No.] to “1” and clicking the [Register] button displays the [Change Part] window. Select the design and color and then click the [Select] button.

A keypad is registered to the specified overlap library number. For more information on the registered details, refer to page 4-14.

If the specified overlap library number is already registered, the following confirmation message is displayed. Select [Yes] to overwrite the overlap library number or select [No] to register the keypad to another overlap library number.
*2 Mouse specification method
Click the [Specify with Mouse] button. A cross-shaped cursor and a rectangle the size of the overlap are displayed.

Click on a position where the rectangle does not protrude outside the screen. The mark that shows the display position of the multi-overlap moves to the clicked position.

- **[Style] tab**
  Set text properties of the entry target.
  Use the [Change Part] button to change parts.

- **Operation/Alarm**
  Set the alarm options.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Alarm</td>
<td>Select this checkbox to use the alarm function.</td>
<td>Selected</td>
</tr>
<tr>
<td>Min.</td>
<td>Set the minimum and maximum entry values. Values outside this range cannot be entered.</td>
<td>-5000 Red</td>
</tr>
<tr>
<td>Max.</td>
<td></td>
<td>5000 Blue</td>
</tr>
<tr>
<td>Word Operation</td>
<td>Not used in this section. For more information, refer to Chapter 5 in the &quot;V8 Series Reference Manual.&quot;</td>
<td>Deselected</td>
</tr>
<tr>
<td>Scaling</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

Changes to the settings on the [Detail], [Comment], and [Display Setting] tabs are not covered in this section.
1.2 Creating Multiple Copies of Numerical Data Displays

1. Select the numerical data display on the screen. Handles are shown around the numerical data display.

2. Click [Edit] → [Multi Copy] or click the [Multi-copy] icon. The [Multi Copy] dialog box is displayed.

3. Set the options as shown below and click [OK]. This copies the numerical data display.
4. Entry Screens

4. Select [View] → [Customize] → [Memory Display].

Memory addresses are displayed at the lower left on each numerical data display. The memory addresses are set from “D100” to “D109”. 

5. Change the settings of each numerical data display. In this section, change the settings to the following.

[Main] tab
- Decimal Point: 1
- Digits: 4
- Display Type: HEX
- Zero Suppress: Deselected
- Display Position: X Coordinate: 400, Y Coordinate: 145

[Operation/Alarm] tab
- Alarm: Deselected
Configuring Multiple Items at Once in the Item Dialog
The settings of multiple items can be configured at once by selecting multiple instances of the same item.

1. Select all of the numerical data display items for configuration.
   The [Num. Display (Multiple Selection)] item dialog box is displayed.

2. Change [Decimal Point] to “1”. All the selected numerical data displays are updated with this change.

This completes the numerical data display and entry key registration process.
1.3 Placing Character Displays and Registering Character Keys

1. Click [Parts] → [Parts List]. The [Parts List] window is displayed.
2. Select [Entry], [Real #1 CHRA.Display].
3. Select a character display part and drag it onto the screen. This places the character display on the screen.
4. Configure each setting in the character display’s item dialog box.
   • [Main] tab
     Set the memory address for writing and select a setting for [Function].

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Memory</td>
<td>Set the memory address for writing.</td>
<td>D110</td>
</tr>
<tr>
<td>Offset Value Designation Memory</td>
<td>Select this checkbox to specify an offset. For more information, refer to the “V8 Series Reference Manual.”</td>
<td>Deselected</td>
</tr>
<tr>
<td>No. of Bytes</td>
<td>Set the number of bytes for the character array. Setting value: 1 to 127</td>
<td>12</td>
</tr>
<tr>
<td>Character Position</td>
<td>Select either flush-left or flush-right for the character display.</td>
<td>Flush Left</td>
</tr>
<tr>
<td>Text Process</td>
<td>Set the order of the 1st byte and 2nd byte in 1 word.</td>
<td>LSB→MSB</td>
</tr>
<tr>
<td>Function</td>
<td>Set the character display function.</td>
<td>Entry Target</td>
</tr>
<tr>
<td>Order INC</td>
<td>Set the order in which the cursor moves when multiple entry targets are placed on the screen.</td>
<td>0</td>
</tr>
<tr>
<td>☐ With Entry Key</td>
<td>Function: Entry Target (enabled when selected) Select this checkbox to add the entry key call function.</td>
<td>Selected</td>
</tr>
<tr>
<td>Overlap ID</td>
<td>Set the overlap ID to be used for showing the character entry keys.</td>
<td>0</td>
</tr>
<tr>
<td>Overlap Library No. Register button*1</td>
<td>Set the overlap library number for registering the character entry keys. Select the desired keyboard by pressing the [Register] button and register the keyboard to the overlap library. If the keyboard is already registered to the overlap library, simply specify the overlap library number. Setting value: 0 to 9999</td>
<td>2</td>
</tr>
</tbody>
</table>

![Image of character display item dialog box with detailed settings]
4. Entry Screens

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Display Position</td>
<td></td>
<td></td>
</tr>
<tr>
<td>X Coordinate</td>
<td>Set the [X Coordinate] and [Y Coordinate] values for the display</td>
<td></td>
</tr>
<tr>
<td>Y Coordinate</td>
<td>position of the overlap.</td>
<td></td>
</tr>
<tr>
<td>Specify with Mouse button</td>
<td>[Specify with Mouse] button: Specify the coordinates by clicking</td>
<td></td>
</tr>
<tr>
<td></td>
<td>with the mouse.</td>
<td></td>
</tr>
<tr>
<td></td>
<td></td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td></td>
<td>X Coordinate:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>100</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Y Coordinate:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>182</td>
</tr>
</tbody>
</table>

*1 Registration method
Setting [Overlap Library No.] to "2" and clicking the [Register] button displays the [Change Part] window. Select [Real #4 [Character TS]] and click the [Select] button.

![Image of the Change Part window]

The character keys are registered to the specified overlap library number. For more information on the registered details, refer to page 4-14.
If the specified overlap library number is already registered, the following confirmation message is displayed.
Select [Yes] to overwrite the overlap library number or select [No] to register the character keys to another overlap library number.

![Image of the confirmation message]

*2 Mouse specification method
Refer to page 4-6.

This completes the character display and entry key registration process.
1.4 Placing Text

This section explains how to place the screen title and text that indicates memory address numbers.

1. Click the [Text] icon ( ). A cross-shaped cursor is displayed.
2. Click on the screen. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box. Change the text color and text size properties.

The completes the screen editing process.
4. Entry Screens

2. Overlap Library

The following items are registered to the overlap library contain the entry keys registered using the [Register] button. These can be used without changing any settings. If size adjustment or color changes are required, change these settings in the [Overlap Library Edit] window.

- Overlap library number 1 (keypad)

- Overlap library number 2 (character keys)

2.1 Editing the Overlap Library

1. Click [Registration Item] → [Overlap Library]. The [Overlap Library] dialog box is displayed.
2. Specify number “1” for the overlap library to which the entry key is registered. The [Overlap Library Edit] dialog box is displayed.

♦ Overlap Settings
1. Click the overlap to display its item dialog box. Properties such as area color and size can be changed in this dialog box.
   - [Main] tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>System Button</td>
<td>Select this checkbox to add a switch function (move/dismiss) to the upper left corner of the overlap area. For more information on the operation of this switch, refer to page 3-14 in “Showing and Hiding Multi-overlaps.”</td>
<td>Deselected</td>
</tr>
</tbody>
</table>

- [Style] tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Set the area color.</td>
<td></td>
</tr>
<tr>
<td>Area</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Change Part</td>
<td>Change the part used for the overlap.</td>
<td></td>
</tr>
</tbody>
</table>
4. Entry Screens

- **[Detail] tab**
  Settings on this tab do not require changing.

- **[Coordinates] tab**
  Set the placement position and size of the overlap. Settings on this tab do not require changing.

The size of the overlap can also be changed by selecting the overlap and dragging the displayed handles.

♦ **Settings of Items Placed on the Overlap**
Edit items on the overlap by clicking [Overlap Editing] → [No. 0] on the right-click menu.

2.2 Entry Icon

An entry icon for configuring keypad settings is displayed at the upper left of the keypad placed on the screen. If this entry icon is not displayed or settings are incorrect, the keypad will not function correctly.

In this section, use the keypad without changing any settings. For more information on the entry icon, refer to Chapter 7 in the “V8 Series Reference Manual.”
2.3 Entry Display Part/Max. Value Display Part/Min. Value Display Part

The entry display part function temporarily displays values entered using the entry keys. The max. value display part and min. value display part functions display the range of values that can be entered using the entry keys. The maximum and minimum values set for [Alarm] when [Function] is set to “Entry Target” are displayed automatically. This section only explains the essential settings for each function.

♦ Overlap Library No. 1

1. Click on the overlap. The numerical data display’s item dialog box is displayed.
2. Configure the numerical data display settings.
   • [Main] tab

   ![Image of a dialog box with settings options]

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Digits</td>
<td>For entry display parts on the TS Series unit, the system automatically refers to the properties set for the entry target. Configure these settings for the purpose of layout. Set the part by referring to the greatest value or the longest display among the entry targets.</td>
<td>5</td>
</tr>
<tr>
<td>Decimal Point</td>
<td></td>
<td>1</td>
</tr>
<tr>
<td>Display Type</td>
<td></td>
<td>DEC (with sign ±)</td>
</tr>
<tr>
<td>Zero Suppress</td>
<td></td>
<td>Selected Flush Right</td>
</tr>
<tr>
<td>Function</td>
<td>Set the function to use.</td>
<td>Entry Display Part Max. Value Display Part Min. Value Display Part</td>
</tr>
</tbody>
</table>

   • [Style] tab
   Set text properties of the entry target. Use the [Change Part] button to change parts.

   • [Detail] tab

   ![Image of a dialog box with settings options]

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Set the ID. Always set the same ID as that shown on the entry icon.</td>
<td>0</td>
</tr>
</tbody>
</table>

   • [Coordinates] tab
   Adjust the placement position.
4. Entry Screens

♦ Overlap Library No. 2
1. Click on the overlap. The character display’s item dialog box is displayed.
2. Configure the character display settings.
   • [Main] tab

   ![Char. Display](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>No. of Bytes</td>
<td>For entry display parts on the TS Series unit, the system automatically</td>
<td>12</td>
</tr>
<tr>
<td></td>
<td>refers to the properties set for the entry target. Configure these</td>
<td></td>
</tr>
<tr>
<td></td>
<td>settings for the purpose of layout. Set the part by referring to the</td>
<td></td>
</tr>
<tr>
<td></td>
<td>greatest value or the longest display among the entry targets.</td>
<td></td>
</tr>
<tr>
<td>Character Position</td>
<td>Select either flush-left or flush-right for the character display.</td>
<td>Flush Right</td>
</tr>
<tr>
<td>Function</td>
<td>Set the function to use.</td>
<td>Entry Display Part</td>
</tr>
</tbody>
</table>

   • [Style] tab
   Set text properties of the entry target.
   Use the [Change Part] button to change parts.

   • [Detail] tab

   ![Char. Display](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Set the ID. Always set the same ID as that shown on the entry icon.</td>
<td>0</td>
</tr>
</tbody>
</table>

   • [Coordinates] tab
   Adjust the placement position.

   The completes the overlap library editing process. The next section covers screen operation after transferring screen data to the TS Series unit.
4. Entry Screens

## Confirming Unit Operation

### 1. Memory Addresses

The memory addresses used in this example are listed below.

<table>
<thead>
<tr>
<th>Memory Address</th>
<th>Memory Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>D100 to 109</td>
<td>Numerical data display (Entry Target)</td>
</tr>
<tr>
<td>D110 to 115</td>
<td>Character display (Entry Target)</td>
</tr>
<tr>
<td>$u16330</td>
<td>Entry mode (Command Memory)</td>
</tr>
<tr>
<td>$u16340</td>
<td>Entry mode (Info Output Memory)/Multi-overlap (Info Output Memory)</td>
</tr>
</tbody>
</table>

* Change to a different memory address to control the entry mode and use information output memory.

### 2. Unit Operation

#### 2.1 Entering Values

1. Press the numerical display for “D100”. This displays the keypad overlap and highlights the value for “D100”.

![Entry Screen](image)

The entry display part displays the current value for “D100”.

The maximum and minimum values are also displayed because an alarm is configured for the “D100” entry target.

If an alarm is configured for the entry target, [Max.] and [Min.] are displayed on the overlap. The [Enter] key cannot be pressed if the entered value is outside the displayed range.
4. Entry Screens

2. Press “3” twice on the keypad. “33” is displayed on the entry display part.

3. Press the [Enter] key. The keypad overlap disappears and the value of “D100” displays “33”. Checking the “D100” address on the PLC should show that “33” is written.

Writing operations for other data are performed in the same manner.

Entering negative values, such as “-200”:
Press “2” “0” “0” “+/-” and then [Enter] on the keypad.
2.2 Entering Text

1. Press the character display for "D110". This displays the character overlap and highlights the value for "D110".

2. Press "D" "A" "T" "E" using the character entry keys. "DATE" is displayed on the entry display part.

3. Press the [Enter] key. The character entry overlap disappears and "DATE" is displayed. Checking the "D110" and "D111" addresses on the PLC should show that "4144Hex" and "4554Hex" are written.
5. Alarm Screens

- Alarm tracking (historical)
  Depending on the ON/OFF state of the relevant bit, the corresponding error message and time information (occurrence/reset) are displayed on a single line. This information is stored in the buffering area as alarm history.

Configure the following settings for [Alarm Tracking] that stores the alarm history.
- Store the alarm history → Buffering area
- Display the stored alarm history → Alarm tracking parts
- Register error messages → Message editing

Keyword
Buffering Area
This area is used to store sampling data. Select either the internal memory (DRAM/SRAM) of the TS Series unit or the external storage device for the storage target.

- Real time alarm display
  History information from alarm tracking can be used to just display the currently occurring error.
### Screen Example

Create the following screens in this section.

**Alarm Tracking**

- Single line display of bit ON and OFF times

- Error History

- Real Time Alarm Display

- Message display of the currently occurring error (bit ON)
1. **Placing Parts**

This section explains how to place alarm tracking parts.

1. Click [Parts] → [Parts List]. The [Parts List] window is displayed.
2. Select [Alarm Tracking].
3. Select the desired part using the [←] and [→] icons or from the drop-down list.
4. Drag the selected part onto the screen. This places the alarm tracking part on the screen.
In addition to the [Parts List], the following four methods are available for placing parts.

1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1. Parts icons

2. [Parts] menu

3. [Catalog] dialog box

4. Wizard ([Parts] menu)

2. Alarm Tracking Parts

The parts that comprise alarm tracking are shown below. Configure detailed settings via the alarm tracking icon. For more information on the operational specifications of other switches, refer to page 5-34.
3. Alarm Tracking Settings

This section explains how to configure the settings for alarm tracking.

1. Click on the alarm tracking part. Red handles and a [Link] item dialog box are displayed.

![Red handle](image1)

2. Click the alarm tracking icon at the upper left corner of the area. The [Alarm Tracking] item dialog box is displayed.

![Alarm tracking icon](image2)

3. Configure the settings for alarm tracking.
### 3.1 [Main] Tab

Configure the following settings.

#### Item Description Setting Value

<table>
<thead>
<tr>
<th>Buffering Area No.</th>
<th>Set the desired buffering area number for storing the alarm history. Setting range: 0 to 11</th>
<th>0</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Message G No.</td>
<td>Set the G No. to which alarm messages are registered. Setting range: 0 to 127 Register or edit messages by clicking [Open]. For more information, refer to &quot;5. Editing Messages.&quot;</td>
<td>0</td>
</tr>
<tr>
<td>History Display</td>
<td>Set the information to display in the alarm tracking area.</td>
<td>Occurrence/ Cancellation Time</td>
</tr>
<tr>
<td>□ Date Display</td>
<td>This setting is valid when [History Display] is set to &quot;Time of Occurrence&quot; or &quot;Occurrence/Cancellation Time&quot;. Select the format for displaying the date when this checkbox is selected.</td>
<td>06/04/01</td>
</tr>
<tr>
<td>□ Year 4-digit Display</td>
<td>This setting becomes active when the [Date Display] checkbox and a Common Era calendar are selected. Select this checkbox to use four digits for displaying the year.</td>
<td>Deselected</td>
</tr>
<tr>
<td>□ Zero Suppress for Year</td>
<td>This setting becomes active when the [Date Display] checkbox and a Common Era calendar are selected. Set whether to enable zero suppression when displaying the year.</td>
<td>Deselected</td>
</tr>
<tr>
<td>□ Zero Suppress for Month-Day</td>
<td>This setting becomes active when the [Date Display] checkbox and a Common Era calendar are selected. Set whether to enable zero suppression when displaying the month and day.</td>
<td>Deselected</td>
</tr>
<tr>
<td>□ Time Display</td>
<td>Select the format for displaying the time when this checkbox is selected.</td>
<td>13:30:20</td>
</tr>
<tr>
<td>Display Order Ascending Order Descending Order</td>
<td>Select a display order. • Ascending Order Errors are displayed with the oldest one at the top. • Descending Order Errors are displayed with the newest one at the top.</td>
<td>Ascending Order</td>
</tr>
<tr>
<td>□ Acknowledge function</td>
<td>Select this checkbox to use the acknowledge function.</td>
<td>Deselected</td>
</tr>
</tbody>
</table>
5. Alarm Screens

3.2 [Style] Tab

Set the text color and properties of error messages.

![Alarm Tracking] Set the message color. Black

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Color</td>
<td>Set the message color.</td>
<td>Black</td>
</tr>
<tr>
<td>Property</td>
<td>Set the properties and transparency of messages.</td>
<td>Transparent</td>
</tr>
<tr>
<td>Bold/Shadow/Italic</td>
<td>Transparent</td>
<td></td>
</tr>
<tr>
<td>Transparent/Not</td>
<td>Transparent</td>
<td></td>
</tr>
<tr>
<td>Windows Font</td>
<td>Select this checkbox to use a Windows font.</td>
<td>Deselected</td>
</tr>
</tbody>
</table>

3.3 [Detail] Tab

The settings on this tab do not require changing in this section.

![Alarm Tracking] Only Primary Cause Display

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>□ Only Primary Cause Display</td>
<td>Select this checkbox to only display primary cause messages.</td>
<td>Deselected</td>
</tr>
<tr>
<td>□ Primary Cause Mark Display</td>
<td>Select this checkbox to display a mark (*) to the left of primary cause messages.</td>
<td>Deselected</td>
</tr>
<tr>
<td>□ Screen Display Screen No.</td>
<td>Select this checkbox to change to the details screen by tapping an alarm message on the unit.</td>
<td>Deselected</td>
</tr>
<tr>
<td>ID</td>
<td>Set the ID.</td>
<td>0</td>
</tr>
</tbody>
</table>

This completes the configuration of the alarm tracking settings. The next section covers buffering area configuration.
4. Buffering Area Settings

Set the buffering area for storing the alarm history.

The buffering area can be partitioned into a maximum of 12 sections (buffers), numbering 0 to 11.

1. Click [Refer to Buffering Status] on the [Main] tab in the [Alarm Tracking] dialog box or click [System Setting] → [Buffering Area Setting].

2. Configure the settings for buffering area number 0.
5. Alarm Screens

♦ Sampling Settings

**Buffering area number 0**

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type Sampling Method</td>
<td>Set the sampling method. The type and method are set automatically when an alarm item is placed on the screen.</td>
<td>Alarm Tracking</td>
</tr>
<tr>
<td>Sampling Cycle</td>
<td>Set the interval for monitoring sampling memory. Setting range: 0 to 65535 sec</td>
<td>0</td>
</tr>
<tr>
<td>Memory Continuous, Individually Memory address specification ON/OFF Data Length Word Count</td>
<td>Set the error memory address and total number of words. Continuous, memory address specification ON: The sampling memory comprises the consecutive addresses starting from the specified memory address. Set the data length of the specified memory address. Continuous, memory address specification OFF: The sampling memory comprises the consecutive addresses starting from the read area and sampling control memory. Individually: The sampling memory comprises the specified memory address. A bit memory address can be specified for each error. Set these addresses on the [Discrete memory/CSV format] tab.</td>
<td>Continuous M00000 Data Length 1-Word Word Count 1</td>
</tr>
</tbody>
</table>

---

♦ Store Target

Set the storage target for sampling data.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary storage target Type</td>
<td>DRAM: Store sampled data in the DRAM area of the unit. This area is cleared when the unit changes to STOP mode (when the power is turned off or the [Main Menu] screen is displayed). SRAM: Store sampled data in the SRAM area of the unit. Data in this area is retained even when the unit changes to STOP mode (when the power is turned off or the [Main Menu] screen is displayed).</td>
<td>SRAM</td>
</tr>
</tbody>
</table>
### 5. Alarm Screens

#### 5.1 Alarm Screens

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary storage target</td>
<td>Set what happens when the specified number of sampling times ([No. of Samples]) is exceeded.</td>
<td>Overwrite</td>
</tr>
<tr>
<td>Full Processing</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>Overwrite: Sampling continues even when the number specified for [No. of Samples] is exceeded. Old data is discarded automatically.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Stop: Sampling stops when the number specified for [No. of Samples] is exceeded.</td>
<td></td>
</tr>
<tr>
<td>Primary storage target</td>
<td>Set the number of history samples to store in the primary storage target. An error occurrence (bit ON) is counted as one sample and error reset (bit OFF) is counted as one sample as well.</td>
<td>1000</td>
</tr>
<tr>
<td>No. of Samples</td>
<td></td>
<td></td>
</tr>
<tr>
<td></td>
<td>If the number of samples is less than the display area size, the roll up and roll down switches do not operate.</td>
<td></td>
</tr>
<tr>
<td>Secondary storage target</td>
<td>Select “Storage” to store history data in the external storage device. History data is stored in BIN file format.</td>
<td>None</td>
</tr>
<tr>
<td>Output media</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Secondary storage target</td>
<td>Set the number of history samples to store in the external storage device. If the number of samples is less than the display area size, the roll up and roll down switches do not operate.</td>
<td>None</td>
</tr>
<tr>
<td>No. of Samples</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Secondary storage target</td>
<td>Select this checkbox to convert the secondary storage target BIN file to a CSV file and save it to the external storage device.</td>
<td>Deselected</td>
</tr>
<tr>
<td>CSV Output</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Secondary storage target</td>
<td>Save the secondary storage target data in a backup folder.</td>
<td>Deselected</td>
</tr>
<tr>
<td>Create Backup File</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

#### Discrete Memory/CSV Format

Configure the sampling memory settings and data format settings for CSV file output to the external storage device when [Memory] is set to “Individually”.

![Discrete Memory/CSV Format](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start Message G No., No.</td>
<td>Set the message group number to which alarm messages are registered.</td>
<td>GNo. 0 No. 0</td>
</tr>
<tr>
<td>CSV Format</td>
<td>Set the alarm format and date and time format when outputting to CSV file.</td>
<td>-</td>
</tr>
<tr>
<td>Memory</td>
<td>Valid when [Memory] is set to “Individually”. Set the error bit corresponding to each message.</td>
<td>-</td>
</tr>
</tbody>
</table>
5. Alarm Screens

5-11

♦ Others
Configure settings on this tab when using time order alarming, e-mail sending or parameter functions.

Since the time order alarming screen is added to page 5-21 "Screen Creation (2)" in this chapter, perform the following settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Message Memorize E-Mail</td>
<td>Displays the message corresponding to each error bit. The configuration can be checked when using the e-mail sending function. Double-click on a cell to display the [Message - Edit] window.</td>
<td>-</td>
</tr>
<tr>
<td>Parameter</td>
<td>Configure the parameter function settings.</td>
<td>None</td>
</tr>
</tbody>
</table>

♦ Sampling Control Memory/Information Output Memory

The sampling control memory is used to control the buffering area and the information output memory is used for outputting the state of the buffering memory.

This completes the configuration of the buffering area settings.
5. Editing Messages

This section explains how to register error messages.

1. Click the alarm tracking icon to display its item dialog box.
2. Click [Main] tab → [Open]. The message editing window for the corresponding group number is displayed.

The [Message - Edit] window can also be displayed with the following method.
Click [Registration Item] → [Message]. The [Message] dialog box is displayed. Set [Group] to "0" and click [OK].
5. Alarm Screens

3. Enter the error message. Sixteen lines of messages can be registered because [Word Count] is set to "1" in the [Buffering Area Setting] dialog box.

<table>
<thead>
<tr>
<th>Line No.</th>
<th>Message</th>
<th>Memory Address</th>
</tr>
</thead>
<tbody>
<tr>
<td>00000</td>
<td>Tank A Error</td>
<td>M00000</td>
</tr>
<tr>
<td>00001</td>
<td>Tank B Error</td>
<td>M00001</td>
</tr>
<tr>
<td>00002</td>
<td>Tank C Error</td>
<td>M00002</td>
</tr>
<tr>
<td>00003</td>
<td>Tank D Error</td>
<td>M00003</td>
</tr>
<tr>
<td>00004</td>
<td>Tank E Error</td>
<td>M00004</td>
</tr>
<tr>
<td>00005</td>
<td>Tank F Error</td>
<td>M00005</td>
</tr>
<tr>
<td>00006</td>
<td>Tank G Error</td>
<td>M00006</td>
</tr>
<tr>
<td>00007</td>
<td>Tank H Error</td>
<td>M00007</td>
</tr>
<tr>
<td>00008</td>
<td>Valve A Error</td>
<td>M00008</td>
</tr>
<tr>
<td>00009</td>
<td>Valve B Error</td>
<td>M00009</td>
</tr>
<tr>
<td>00010</td>
<td>Valve C Error</td>
<td>M00010</td>
</tr>
<tr>
<td>00011</td>
<td>Valve D Error</td>
<td>M00011</td>
</tr>
<tr>
<td>00012</td>
<td>Valve E Error</td>
<td>M00012</td>
</tr>
<tr>
<td>00013</td>
<td>Valve F Error</td>
<td>M00013</td>
</tr>
<tr>
<td>00014</td>
<td>Valve G Error</td>
<td>M00014</td>
</tr>
<tr>
<td>00015</td>
<td>Valve H Error</td>
<td>M00015</td>
</tr>
</tbody>
</table>

The underline in messages is used to indicate the line feed position. If an underline is present where there are no characters, it indicates that there is a space character present. The underline can be hidden by clicking [Display] → [Underline] to remove the checkmark.
4. When registration is complete, click [File] menu → [Close].

The window can also be closed by clicking here.

In message editing there are 128 groups (0 to 127) and a maximum of 256 lines of messages can be registered in each group (for a maximum of 32768 lines). A maximum of 127 one-byte characters or 63 two-byte characters can be registered to each line.

If [Word Count] is set to a value greater than “16”, one group will not be enough so use the next group.

Example:
Word Count: 17 (= 16 bits × 17 words = 272 lines)
Start Message G No.: 0
With these settings, use “G No. 0 No. 0” to “G No. 1 No. 15”.

This completes the message registration process.
6. **SRAM/Clock Settings**

SRAM format settings must be configured because [Primary storage target] - [Type] was set to "SRAM" for data retention after the power is turned off. Clock settings must also be configured because the clock display is set to use the internal clock of the TS Series unit.

1. Click [System Setting] → [Unit Setting] → [SRAM/Clock].

2. Configure the following settings in the [SRAM/Clock Setting] dialog box. Do not change any of the other settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Built-in Clock</td>
<td>&lt;&lt;table details&gt;&gt;</td>
<td>Selected</td>
</tr>
<tr>
<td>SRAM Auto Format</td>
<td>&lt;&lt;table details&gt;&gt;</td>
<td>Selected</td>
</tr>
<tr>
<td>Primary Storage of Sampling</td>
<td>&lt;&lt;table details&gt;&gt;</td>
<td>-</td>
</tr>
</tbody>
</table>

3. Click [OK]. This completes the configuration of the SRAM and clock settings.
7. Placing Text

This section explains how to place the screen title.

1. Click the [Text] icon. A cross-shaped cursor is displayed.
2. Click on the screen. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text again to display its item dialog box. Change the text color and text size properties.

The completes the screen editing process.
8. Checking the Display Area Size

Check how registered messages will be displayed on the unit in V-SFT.

1. Click [View] → [Display Environment]. The [Display Environment] dialog box is displayed.

2. Select the [Display Message] checkbox in the [Detail] list and click [OK]. This displays the messages in the display area.

3. Adjust the size of each part as necessary. For more information on the adjustment method, refer to "8.1 Changing Parts and Adjusting Size."
8.1 Changing Parts and Adjusting Size

The part placed in this example links together multiple parts into a single part. In this linked state, all individual parts are moved, enlarged, and reduced together. The link between these individual parts must be canceled in order to move, enlarge, and reduce them separately. When editing is complete, the individual parts can be linked again.

**Distinguishing Linked Parts**

If multiple parts are selected at the same time and surrounded with red handles when clicking on a part grouping, these parts are linked together. Linked parts all share the same ID.

**Canceling Links**

1. Click on the placed part. The entire part that includes the display area and switches is selected and surrounding with red handles.

2. Click [Link] → [Link Cancel] on the right-click menu. The handle color changes from red to blue and each individual part becomes surrounded by handles.

3. Move, enlarge, or reduce each part as necessary.
♦ Changing Parts
Perform the following procedure to change the part design and color.

1. Select the part for changing to display its item dialog box.
2. Click [Style] → [Change Part]. The [Change Part] window is displayed.
3. Select the desired part from the list.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Maintain Size</td>
<td>Deselected: Change to the default size.</td>
</tr>
<tr>
<td></td>
<td>Selected: Maintain the size prior to changing.</td>
</tr>
<tr>
<td>Pattern Change</td>
<td>The pattern image of OFF, ON, and patterns up to P128 can be checked.</td>
</tr>
<tr>
<td>Change Part Color</td>
<td>Change the color.</td>
</tr>
<tr>
<td>Part Type Change</td>
<td>Change the part type.</td>
</tr>
<tr>
<td></td>
<td>Real/Sign/3D</td>
</tr>
<tr>
<td></td>
<td>Circle/Square/Plant/Icon etc.</td>
</tr>
</tbody>
</table>

4. Select the part properties for changing and click [Select] to change the part on the screen.
5. Alarm Screens

◆ Linking Parts

1. Select all the individual parts used in alarm tracking.

2. Click [Link] → [Link] on the right-click menu. The handle color changes to red and the individual parts are linked together.

- Linking cannot be performed if any parts unrelated to alarm tracking are selected.
- Linking individual parts together changes their IDs to the same ID as the alarm tracking icon. This ID can be displayed by clicking [Detail] → [ID] on the right-click menu.

- If the ID number differs between individual parts, alarm tracking will not work properly on the TS Series unit.
This section explains how to create a real time alarm display using the buffering area configured for screen number 3. This screen will only display errors that are currently occurring.

1. **Placing Parts**

1. Click [Parts] → [Parts List] or double-click [Parts List] in the [Catalog] dialog box. The [Parts List] window is displayed.
2. Select [Time Order Alarming].
3. Place the linked real time alarm display parts on the screen.
5. Alarm Screens

2. Real Time Alarm Display Parts

The parts that comprise the real time alarm display are shown below. Configure detailed settings via the real time alarm display icon. For more information on the operational specifications of other switches, refer to page 5-34.

3. Real Time Alarm Display Settings

This section explains how to configure the settings for the real time alarm display.

1. Click on the real time alarm display part. Red handles and a [Link] item dialog box are displayed.
2. Click the real time alarm display icon at the upper left corner of the area. The [Time Order Alarming] dialog box is displayed.

3. Configure the settings for the real time alarm display.

♦ [Main] Tab
Configure the following settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Description</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Buffering Area No.</td>
<td>Set the desired buffering area number for storing the alarm history.</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Use the setting from “Screen Creation (1)”.</td>
<td></td>
</tr>
<tr>
<td>Action Area</td>
<td>Set the position to display error messages on the screen.</td>
<td>Display Area</td>
</tr>
<tr>
<td>□ Time Display</td>
<td>Deselected: Only display error messages.</td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>Selected: Display the time that errors occur and the corresponding messages.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Max. 15 one-byte characters for time display 04/01 13:30:20</td>
<td></td>
</tr>
<tr>
<td>Display Order</td>
<td>Select a display order.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Chronological Order Errors are displayed with the oldest one at the top.</td>
<td>Chronological Order</td>
</tr>
<tr>
<td></td>
<td>Newest Order Errors are displayed with the newest one at the top.</td>
<td></td>
</tr>
</tbody>
</table>
5. Alarm Screens

Do not change the settings on the [Sub-action], [Style], and [Detail] tabs in this section.

This completes the configuration of the real time alarm display settings.

4. Placing Text

This section explains how to place the screen title.

1. Click the [Text] icon. A cross-shaped cursor is displayed.
2. Click on the screen. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text to display its item dialog box. Change the text color and text size properties.
5. Creating a Switch for Changing to Another Screen

This section explains how to place a switch that changes between screen 3 (created in “Screen Creation (1)”) and screen 4 (created in “Screen Creation (2)”) when pressed.

1. Place a switch.
2. Set [Function] to “Screen” in the switch’s item dialog box and set [Screen No.] to the number of the destination screen.

Screen Creation (1)

![Screen Creation (1) Image]

Screen Creation (2)

Switch
Function: Screen 3

![Screen Creation (2) Image]

3. Adjust the switch color and position.

This completes the screen creation process. The next section covers confirming screen operation on the TS Series unit.
## Confirming Unit Operation

### 1. Memory Addresses and Registered Messages

The memory addresses used in this example are listed below.

<table>
<thead>
<tr>
<th>Memory Address</th>
<th>Memory Contents</th>
<th>Message</th>
</tr>
</thead>
<tbody>
<tr>
<td>D00000</td>
<td>Read area</td>
<td></td>
</tr>
<tr>
<td>D00001</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D00002</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D00003-00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D00003-01</td>
<td>Sampling control memory (Buffer No. 0)</td>
<td>-</td>
</tr>
<tr>
<td>D00003-02</td>
<td></td>
<td></td>
</tr>
<tr>
<td>D00003-03</td>
<td></td>
<td></td>
</tr>
<tr>
<td>M00000</td>
<td>Sampling memory</td>
<td>GNo. 0 No. 0 Tank A Error</td>
</tr>
<tr>
<td>M00001</td>
<td></td>
<td>GNo. 0 No. 1 Tank B Error</td>
</tr>
<tr>
<td>M00002</td>
<td></td>
<td>GNo. 0 No. 2 Tank C Error</td>
</tr>
<tr>
<td>M00003</td>
<td></td>
<td>GNo. 0 No. 3 Tank D Error</td>
</tr>
<tr>
<td>M00004</td>
<td></td>
<td>GNo. 0 No. 4 Tank E Error</td>
</tr>
<tr>
<td>M00005</td>
<td></td>
<td>GNo. 0 No. 5 Tank F Error</td>
</tr>
<tr>
<td>M00006</td>
<td></td>
<td>GNo. 0 No. 6 Tank G Error</td>
</tr>
<tr>
<td>M00007</td>
<td></td>
<td>GNo. 0 No. 7 Tank H Error</td>
</tr>
<tr>
<td>M00008</td>
<td></td>
<td>GNo. 0 No. 8 Valve A Error</td>
</tr>
<tr>
<td>M00009</td>
<td></td>
<td>GNo. 0 No. 9 Valve B Error</td>
</tr>
<tr>
<td>M00010</td>
<td></td>
<td>GNo. 0 No. 10 Valve C Error</td>
</tr>
<tr>
<td>M00011</td>
<td></td>
<td>GNo. 0 No. 11 Valve D Error</td>
</tr>
<tr>
<td>M00012</td>
<td></td>
<td>GNo. 0 No. 12 Valve E Error</td>
</tr>
<tr>
<td>M00013</td>
<td></td>
<td>GNo. 0 No. 13 Valve F Error</td>
</tr>
<tr>
<td>M00014</td>
<td></td>
<td>GNo. 0 No. 14 Valve G Error</td>
</tr>
<tr>
<td>M00015</td>
<td></td>
<td>GNo. 0 No. 15 Valve H Error</td>
</tr>
<tr>
<td>$u16340-00</td>
<td>Info output memory (Buffer No. 0)</td>
<td>-</td>
</tr>
<tr>
<td>$u16340-01</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$u16340-02</td>
<td></td>
<td></td>
</tr>
<tr>
<td>$u16340-03</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
1.1 Sampling Control Memory

The sampling control memory is used to control the operation and state of the buffering area function. The allocation and contents of sampling control memory differ in the following manner according to the buffering area settings.

In this example, [Buffering Area separate settings] are not set, so memory from the [Read Area] is allocated consecutively in 3 word blocks from “D0”. In addition, the sampling control memory becomes bit numbers “00” through “03” of “D00003” because buffer number 0 is being used.

- Buffering Area separate settings: Not set
  Memory from the [Read Area] is allocated consecutively in 3 word blocks from “D0”.

---

<table>
<thead>
<tr>
<th>Sampling control memory</th>
<th>MSB</th>
<th>LSB</th>
</tr>
</thead>
<tbody>
<tr>
<td>15 14 13 12 11 10 09 08</td>
<td>U S R T</td>
<td>U S R T</td>
</tr>
</tbody>
</table>

Where “n” is the read area:
- n + 3
- n + 4
- n + 5

Buffer No. 3 Buffer No. 2 Buffer No. 1 Buffer No. 0
Buffer No. 7 Buffer No. 6 Buffer No. 5 Buffer No. 4
Buffer No. 11 Buffer No. 10 Buffer No. 9 Buffer No. 8

The details of each bit are described below.

T: Trigger
This bit is not used when [Type] is set to “Alarm”.

R: Reset
When this bit is set to “ON”, data in the specified buffer is cleared and sampling stops.
When this bit is set to “OFF”, sampling is started.

S: Normal operation bit
This bit is only valid when [Type] is set to “Alarm” and [Sampling Method] is set to “Alarm Tracking”. This bit is used to obtain more detailed alarm information by performing control in conjunction with the state of the sampling bit.

U: Sampling bit
This bit is only valid when [Type] is set to “Alarm” and [Sampling Method] is set to “Alarm Tracking”. This bit is used to obtain more detailed alarm information by performing control in conjunction with the state of the normal operation bit.

1.2 Sampling Memory

This error memory is used for monitoring in order to store alarm history. The memory used differs depending on the setting of the [Memory] checkbox ( ) in the [Buffering Area Settings] dialog box.

In this example, the sampling memory is “M00000” to “M00015” because the [Memory] checkbox is selected, the memory address is set to “M00000”, and [Data Length] is set to “1-Word”.

---
2. Unit Operation

This section explains how to confirm screen operation after transferring screen data to the unit.

2.1 SRAM Format/Clock Settings

The message "Error:161 (24:)") is displayed immediately after transferring screen data to a new unit. In this case, execute [Format of SRAM] on the [Main Menu] screen. Also configure the settings for the built-in clock on the same screen.

Subsequent screen data transfers to units that have been formatted will not result in this error.*1 SRAM data is retained until the battery in the unit runs out. If the unit is turned off when the battery has run out, the SRAM data is erased. In this case, reformat the SRAM area.

Unit SRAM Area

1. The message “Error:161 (24:) The screen data does not match the SRAM area format.” is displayed after transferring screen data to the unit.

Data Loading...

Error:161(24:)
The screen data does not match the SRAM area format.
2. Press and hold your finger on any of the four screen corners (2 cm squares) for more than two seconds and then release your finger.

3. Next, press any of the remaining corners for more than two seconds within one second of releasing the first corner to display a system menu on the right side of the screen.


5. Press the [Main Menu] switch and then press [SRAM/Clock]. The [SRAM/Clock Adjustment] screen is displayed.
5. Alarm Screens


7. Under [Date and Time Adjustment] on the same screen, set the correct date and time and press [Set]. The date and time at the upper right of the screen are updated.

8. Press the [Return] switch to return to the [Main Menu] screen. The error message disappears.

2.2 Executing Sampling

1. An error occurred on tank A ("M00000" error bit turned ON). The message “Tank A Error” and the time of occurrence are displayed.

2. An error occurred on tank B ("M00001" error bit turned ON). The message “Tank B Error” and the time of occurrence are displayed.

3. An error occurred on valve H ("M00015" error bit turned ON). The message “Valve H Error” and the time of occurrence are displayed.
4. Errors occurred on valves C, D, and E ("M00010", "M00011", and "M00012" error bits turned ON). The messages "Valve C Error", "Valve D Error" and "Valve E Error" and the times of occurrence are displayed.

5. The error on tank A was reset ("M00000" turned OFF). The reset time of the "Tank A Error" is displayed.

6. The error on tank B was reset ("M00001" turned OFF). The reset time of the "Tank B Error" is displayed.
7. The error on valve D was reset ("M00011" turned OFF). The reset time of the "Valve D Error" is displayed. The messages of errors that have not been reset are for valves C, E, and H.

8. Change the screen using the [Screen3] switch. Only the error messages for the errors that have not been reset are displayed.
2.3 Operating Switches

Use switches to check the error history.

1. Press the switches on the right side of the area. A cursor is displayed. The graph return switch flashes.

2. The roll up and roll down switches can move the cursor and next block and previous block switches can change between pages.

3. Pressing the graph return switch causes the cursor to disappear and returns to the latest display.
4. Press the [Delete] switch with the cursor on screen.

5. The selected history entry is deleted.
### Switch Functions

The following switch functions are used in alarm tracking and real-time alarm display.

![Error History](image)

<table>
<thead>
<tr>
<th>No</th>
<th>Function</th>
<th>Description</th>
<th>Alarm</th>
<th>Relay</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Roll up</td>
<td>Scroll one line toward the newest history entry. If all entries cannot be displayed at once, one entry scrolls into view at a time.</td>
<td></td>
<td>O</td>
</tr>
<tr>
<td>2</td>
<td>Roll down</td>
<td>Scroll one line toward the oldest history entry. If all entries cannot be displayed at once, one entry scrolls into view at a time.</td>
<td></td>
<td>O</td>
</tr>
<tr>
<td>3</td>
<td>Next block</td>
<td>Scroll one page toward the newest history entry.</td>
<td></td>
<td>O</td>
</tr>
<tr>
<td>4</td>
<td>Previous block</td>
<td>Scroll one page toward the oldest history entry.</td>
<td></td>
<td>O</td>
</tr>
<tr>
<td>5</td>
<td>Graph return</td>
<td>This button flashes in conjunction with the cursor when any of the roll up, roll down, next block, or previous block switches are pressed. Pressing this switch when it is flashing returns to the latest display where the switch stops flashing and the cursor disappears.</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>6</td>
<td>Change DISPOrder</td>
<td>Change the display order between ascending order and descending order.</td>
<td></td>
<td>O</td>
</tr>
<tr>
<td>7</td>
<td>Display Change-over</td>
<td>This switch is only available when the [Date Display] checkbox or the [Time Display] checkbox is selected in the [Alarm Tracking] dialog box (page 5-5). Pressing this switch changes between date display and time display.</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>8</td>
<td>Reset</td>
<td>Press this switch once to turn on its lamp and then press it again within two seconds to clear the contents of the buffering area. Sampling starts again immediately after the buffering area is cleared. If the switch is not pressed again within two seconds, the switch’s lamp turns off and resetting is nullified.</td>
<td></td>
<td>X</td>
</tr>
<tr>
<td>9</td>
<td>DELETE</td>
<td>Delete the history entry selected with the cursor. This operation only removes the entry from the display area and does not affect the total frequency of occurrence display or total time of occurrence display.</td>
<td></td>
<td>O</td>
</tr>
</tbody>
</table>
This section explains how to use trend sampling to display line graphs of data that changes over time. Trend sampling accumulates changing data in the buffering area so that previous data can be checked for trends.

Trend sampling can display a maximum of 16 graph lines in a single area.

Configure the following two settings in order to use trend sampling.

- Accumulate changing data → Buffering area settings
- Display accumulated data → Trend sampling settings

**Keyword**

**Buffering Area**

This area is used to store sampling data. Select either the internal memory (DRAM/SRAM) of the TS Series unit or the external storage device for the storage target.
6. Trend Screen (Trend Sampling)

Contents

Screen Example .................................................................................................................. page 6-2
Screen Configuration .......................................................................................................... page 6-3
  1. Placing Parts ............................................................................................................. page 6-3
  2. Trend Sampling Parts ............................................................................................... page 6-4
  3. Trend Sampling Settings .......................................................................................... page 6-5
  4. Adjusting the Display Area Size ............................................................................. page 6-15
  5. Buffering Area Settings ........................................................................................... page 6-15
  6. SRAM/Clock Settings ............................................................................................. page 6-23
  7. Placing Text ............................................................................................................ page 6-24
Checking Operation on the Unit ........................................................................................ page 6-25
  1. Memory Addresses ................................................................................................. page 6-25
  2. Unit Operation ........................................................................................................ page 6-27

Screen Example

Create the following screen in this section.

![Trend Sampling Screen Example](image_url)
6. Trend Screen (Trend Sampling)

Screen Configuration

1. Placing Parts

Place the trend sampling part on the screen.

1. Click [Parts] → [Parts List].
2. Select [Trend Sampling].
3. Select the part using the [←] and [→] icons or from the drop-down list.
4. Drag the selected part onto the screen. This places the trend sampling part on the screen.
In addition to the [Parts List], the following four methods are available for placing parts.

1. Placement from the parts icons
2. Placement from the [Parts] menu
3. Placement from the [Catalog] dialog box
4. Placement using the wizard

1. Parts icons

2. [Parts] menu

3. [Catalog] dialog box

4. Wizard ([Parts] menu)

The parts that comprise trend sampling are shown below.

- Sampling count display
- Cursor point value display
- Sampling time display
- Trend sampling
- Sampling time display (end point of display)
- Reset switch
- Next block switch
- Roll up switch
- Roll down switch
- Previous block switch
- Return switch

- Reduce display
- Enlarged display
- Sampling time display (start point of display)
3. Trend Sampling Settings

Configure the settings for trend sampling.

1. Click the trend sampling area on the screen. The [Link] item dialog box is displayed.

2. Click on display area again. The [Trend Sampling] item dialog box is displayed.

3. Configure the settings for trend sampling.
6. Trend Screen (Trend Sampling)

### 3.1 [Main] Tab

Set the number of graph lines and the number of plot points.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Buffering Area No.</td>
<td>Set the buffering area number for storing data. Setting range: 0 to 11</td>
<td>1</td>
</tr>
<tr>
<td></td>
<td>Set or check the buffering area numbers by clicking the [Refer to Buffering Status] button. For more information, refer to “Buffering Area Settings” on page 6-19.</td>
<td></td>
</tr>
<tr>
<td>X Axis Data Points</td>
<td>Set the number of points used to display data. Setting range: 3 to 800</td>
<td>13</td>
</tr>
<tr>
<td></td>
<td>Set the number of points to less than the size of the display area.</td>
<td></td>
</tr>
<tr>
<td>Graph Setting</td>
<td>Set the number of graph lines. Setting range: 0 to 15</td>
<td>No.0 No.1 Yes</td>
</tr>
<tr>
<td></td>
<td>Configure the settings for each graph using the [Edit] button. For more information, refer to “Graph Settings” (page 6-7).</td>
<td></td>
</tr>
<tr>
<td>Direction</td>
<td>Set the direction to draw graph lines.</td>
<td>→</td>
</tr>
</tbody>
</table>

![Graph Diagram](image.png)
6. Trend Screen (Trend Sampling)

♦ Graph Settings
Set the properties of each graph line.

- Graph No. 0

- Graph No. 1

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Graph No. 0 Setting Value</th>
<th>Graph No. 1 Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sampling Buffer Word No.</td>
<td>Set which word of data to display as a trend from the data stored in the buffering area. Setting range: 0 to 128</td>
<td>0</td>
<td>1</td>
</tr>
<tr>
<td>Data Length</td>
<td>Set the data length of the sampling data. Setting range: 1-Word/2-Word</td>
<td>1</td>
<td>1</td>
</tr>
<tr>
<td>Graph Min. Value</td>
<td>Set the minimum and maximum values for sampling data. Select constants for a fixed range and memory for a variable range.</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Graph Max. Value</td>
<td>Setting range: 1-Word: -32768 to 32767</td>
<td>40</td>
<td>100</td>
</tr>
<tr>
<td>Line Graph Marker</td>
<td>Set the line type or point type in addition to color.</td>
<td>Solid line Black</td>
<td>Dotted line Blue</td>
</tr>
</tbody>
</table>

[Set Selected] Button

The [Set Selected] button is convenient to use when the settings required for data length, graph minimum value, and graph maximum value are all the same.

1. Select the number checkboxes of all the trends for use.
2. Click the [Set Selected] button. The [Set Selected] dialog box is displayed.
3. Set values for [Data Length], [Graph Min. Value], and [Graph Max. Value] and click [OK]. This configures the [Data Length], [Graph Min. Value], and [Graph Max. Value] settings for the selected trend numbers all at once.
6. Trend Screen (Trend Sampling)

3.2 [Reference Line] Tab

Lines of reference can be displayed on the graph area. A maximum of four lines can be displayed at once. This function is not used in this example.

3.3 [Style] Tab

Settings such as area color can be configured. These settings are not changed in this example.

3.4 [Scale] Tab

Graphs can display a scale along the right, left, top, or bottom side. In this example, scales are displayed along the right, left, and bottom sides.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>□Set scale display</td>
<td>Select this checkbox to display scales.</td>
<td>Selected</td>
</tr>
<tr>
<td>Color Back Color</td>
<td>Set the color of the major and minor tick marks and axis lines of the scale. This setting is common to all left, right, bottom, and top sides.</td>
<td>Color: Black Back Color: White</td>
</tr>
<tr>
<td>Length of small scale</td>
<td>Set the length of the minor tick marks of the scale. This setting is common to all left, right, bottom, and top sides. Range: 1 to 16 The thickness of the markings is fixed.</td>
<td>Deselected</td>
</tr>
<tr>
<td>Left Right Bottom Top</td>
<td>Select the corresponding checkboxes on these tabs to display a scale, grid lines, and numbers. For more information, refer to the next page.</td>
<td>Left Right Bottom Selected</td>
</tr>
</tbody>
</table>
6. Trend Screen (Trend Sampling)

[Left] Tab

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scale</td>
<td>Set whether to display a scale.</td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>- Selected</td>
<td></td>
</tr>
<tr>
<td></td>
<td>- Deselected</td>
<td></td>
</tr>
</tbody>
</table>

- [Image of the Trend Sampling software interface]
### 6. Trend Screen (Trend Sampling)

#### Small scale alignment
- **Equal divide (unit based on [No. of divisions])**
  Minor tick marks are equally spaced according to the set number of divisions along the axis line.

  \[
  \text{No. of Divisions: 4}
  \]

- **Equal interval (unit based on [No. of intervals])**
  Minor tick marks are spaced at the specified interval based on the range (maximum and minimum values of the specified graph or an arbitrary setting value) set under [Range Setting].

  \[
  \text{Interval: 25}
  \text{Graph No. 0}
  \text{Graph Min. Value: 0}
  \text{Graph Max. Value: 100}
  \]

  \[
  \text{Interval: 1}
  \text{Scale value: 0 to 4}
  \]

#### Make small scales larger every n scales.
Select this checkbox to display major tick marks. The major tick mark is twice the length of the minor. The thickness of the markings is fixed.

#### Grid Line
Select this checkbox to display grid lines at the positions of major and minor tick marks of the scale. Set the color and line type of grid lines. It is possible to only display grid lines at the positions of major tick marks.

- **Major tick marks only**
- **Major/minor tick marks**
6. Trend Screen (Trend Sampling)

6-11

Screen Configuration

These settings are the same as for the [Left] tab. In this example, configure the following settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>□ Num. Display</td>
<td>Select this checkbox to display reference values based on the range (maximum and minimum values of the specified graph or an arbitrary setting value) set under [Range Setting].</td>
<td>Selected Black</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Display only large scale</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Selected</td>
</tr>
<tr>
<td></td>
<td>Interval: 25</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Graph No. 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Graph Min. Value: 0</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Graph Max. Value: 100</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Interval: 1</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Scale value: 0 to 4</td>
<td></td>
</tr>
</tbody>
</table>

*1 When the graph direction is [↑/↓], numbers are displayed based on the setting of [X Axis Data Points] on the [Main] tab or [Set values] under [Range Setting].

**[Right] Tab**

These settings are the same as for the [Left] tab. In this example, configure the following settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>□ Scale</td>
<td>Selected</td>
</tr>
<tr>
<td>Small scale alignment</td>
<td>Equal divide 4</td>
</tr>
<tr>
<td>□ Make small scales larger every n scales.</td>
<td>Deselected</td>
</tr>
</tbody>
</table>
6. Trend Screen (Trend Sampling)

♦ [Bottom] Tab

- **Scale**
  - Set whether to display a scale.
  - **Selected**
  - **Deselected**
  - Setting: **Selected**

- **Small scale alignment**
  - Equal divide (unit based on [No. of divisions])
    - Minor tick marks are equally spaced according to the set number of divisions along the axis line.
    - No. of Divisions: 4

  - Equal interval (unit based on [No. of intervals])
    - Minor tick marks are spaced at the specified interval based on the setting of [X Axis Data Points] on the [Main] tab or the range of [Set values] under [Range Setting].
    - Interval: 2
    - X Axis Data Points: 11
    - Interval: 5
    - Range: 0 to 20
### Item

<table>
<thead>
<tr>
<th>Make small scales larger every n scales.</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select this checkbox to display major tick marks. The major tick mark is twice the length of the minor. The thickness of the markings is fixed.</td>
<td>Selected Every 3 marks</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Grid Line Color Line Type</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select this checkbox to display grid lines at the positions of major and minor tick marks of the scale. Set the color and line type of grid lines. It is possible to only display grid lines at the positions of major tick marks.</td>
<td>Selected White Display only large scale</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Num. Display</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select this checkbox to display reference values based on the setting of [X Axis Data Points] on the [Main] tab or the range of [Set values] under [Range Setting].¹</td>
<td>Selected Black</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>Range Setting</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Settings in this area are valid when [Small scale alignment] is set to “Equal interval” and the [Num. Display] checkbox is selected. Refer to the setting of each option.</td>
<td>Match with the specified graph No. 0</td>
<td></td>
</tr>
</tbody>
</table>

¹ When the graph direction is [↑/↓], numbers are displayed based on the range (maximum and minimum values of the specified graph or an arbitrary setting value) set for [Range Setting].

[Top] Tab

These settings are the same as for the [Bottom] tab. These settings are not used in this example.
### 3.5 [Detail] Tab

Configure the settings for displaying or hiding trend sampling as well as zooming in and out of the graph.

![Trend Sampling Screen](image)

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Control Memory</td>
<td>This memory address is associated with displaying or hiding graph line numbers 0 to 15. Each graph line is displayed or hidden when the corresponding bit is set (ON) or reset (OFF).</td>
<td>Deselected</td>
</tr>
<tr>
<td></td>
<td>Internally, each graph line is displayed or hidden when the corresponding bit is set (ON) or reset (OFF).</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Zooming in: actual size → 2 times → 4 times → 8 times</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Zooming out: 8 times → 4 times → 2 times → actual size</td>
<td></td>
</tr>
<tr>
<td></td>
<td>External Use switches for zooming in and out. The graph is zoomed in or out according to the value specified in the command memory.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0: Actual size 1: 2 times 2: 4 times 3: 8 times</td>
<td></td>
</tr>
<tr>
<td>Zooming in and out Internal/Command Memory</td>
<td>These are the settings for zooming in and out of graphs.</td>
<td>Internal</td>
</tr>
<tr>
<td></td>
<td>Internal Use switches for zooming in and out.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>External The graph is zoomed in or out according to the value specified in the command memory.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>0: Actual size 1: 2 times 2: 4 times 3: 8 times</td>
<td></td>
</tr>
<tr>
<td>Process Cycle</td>
<td>Set the read cycle for the command memory. Redrawing is performed at the following timings.</td>
<td>-</td>
</tr>
<tr>
<td>High Speed, Low Speed, Refresh</td>
<td>High Speed Every cycle</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Low Speed Once in several cycles</td>
<td></td>
</tr>
<tr>
<td></td>
<td>One cycle when the screen is opened</td>
<td></td>
</tr>
<tr>
<td></td>
<td>At the leading edge (0 → 1) of bit 15 (data read refresh) in read area “n + 1”</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Refresh At the leading edge (0 → 1) of bit 15 (data read refresh) in read area “n + 1”</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Macro command TREND_REFRESH</td>
<td></td>
</tr>
<tr>
<td>ID</td>
<td>Set the ID. All the parts used in trend sampling must be set to the same ID.</td>
<td>0</td>
</tr>
<tr>
<td></td>
<td>Switches Roll Up/Roll Down/Next Block/Previous Block/Reset/Graph Return/Zoom In/Zoom Out</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Number display Sample count display/sample time display/cursor value display</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Display area</td>
<td></td>
</tr>
</tbody>
</table>
4. Adjusting the Display Area Size

The size of the required display area in trend sampling changes depending on the setting for [X Axis Data Points]. For this reason, size adjustment must be performed after settings are configured.

The part placed in this example links together multiple parts into a single part. In this linked state, all individual parts are moved, enlarged, and reduced together. The link between these individual parts must be canceled in order to select them separately. When editing is complete, the individual parts can be linked again.

Distinguishing Linked Parts

If multiple parts are selected at the same time with red handles when clicking on a part, these parts are linked together. Linked parts all share the same ID.

♦ Canceling Links

1. Click on the placed part. The entire part that includes the display area and switches is selected and surrounded with red handles.
2. Click [Link] → [Link Cancel] on the right-click menu. The handle color changes from red to blue and each individual part becomes surrounded by handles. Adjust the size, change parts, and move parts as required.
Size Adjustment

1. Click the trend sampling display area.

2. Place the mouse cursor over a handle located on a margin. The mouse cursor changes to a ↔ mark.

3. Drag the handle with the mouse cursor displayed as ↔. The size is adjusted automatically.
6. Trend Screen (Trend Sampling)

♦ Linking Parts
1. Select all the individual parts used in trend sampling.

2. Click [Link] → [Link] on the right-click menu. The handle color changes to red and the individual parts are linked together.

- Linking cannot be performed if any parts unrelated to trend sampling are selected.
- Linking individual parts together changes their IDs to the same ID as the trend sampling icon. This ID can be displayed by clicking [Detail] → [ID] on the right-click menu.

- If the ID number differs between individual parts, trend sampling will not work properly on the TS Series unit.
5. Buffering Area Settings

Set the buffering area for storing the trend sampling history. Use buffering area number 1 in this example because buffering area number 0 is used for alarms.

The buffering area can be partitioned into 12 sections, numbering 0 to 11.

1. Click [Refer to Buffering Status] on the [Main] tab in the [Trend Sampling] dialog box or click [System Setting] → [Buffering Area Setting].

2. Configure the settings for buffering area number 1.
6. Trend Screen (Trend Sampling)

♦ Sampling Settings

Buffering area number 1

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Type</td>
<td>Set the sampling method.</td>
<td>Trend Bit Synchronization</td>
</tr>
<tr>
<td>Sampling Method</td>
<td>Bit Synchronization: Data is stored at the edge of the OFF → ON trigger bit. Constant Sampling: Data is stored at the specified interval (= [Sampling Cycle]).</td>
<td></td>
</tr>
<tr>
<td>Sampling Cycle</td>
<td>Set the interval for monitoring sampling memory and the trigger bit. Setting range: 0 to 65535 sec</td>
<td>0</td>
</tr>
<tr>
<td>High Speed</td>
<td>Continuous, memory address specification ON/ OFF Data Length Word Count</td>
<td>Continuous D200 Data Length 1-Word Word Count 2</td>
</tr>
<tr>
<td>Memory</td>
<td>Set the sampling memory address and total number of words. Continuous, memory address specification ON: The sampling memory comprises the consecutive addresses starting from the specified memory address. Set the data length of the specified memory address. Continuous, memory address specification OFF: The sampling memory comprises the consecutive addresses starting from the read area and sampling control memory. Individually: The sampling memory comprises the specified memory address. Set these addresses on the [Discrete memory/CSV format] tab.</td>
<td></td>
</tr>
</tbody>
</table>

♦ Store Target

Set the storage target for sampling data.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Primary storage target Type</td>
<td>DRAM: Store sampled data in the DRAM area of the unit. This area is cleared when the unit changes to STOP mode (when the power is turned off or the [Main Menu] screen is displayed). SRAM: Store sampled data in the SRAM area of the unit. Data in this area is retained even when the unit changes to STOP mode (when the power is turned off or the [Main Menu] screen is displayed).</td>
<td>SRAM</td>
</tr>
</tbody>
</table>
Discrete Memory/CSV Format

Configure the sampling memory settings and data format settings for CSV file output to the external storage device when [Memory] is set to "Individually".

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>CSV Format</td>
<td>Set the date and time format when outputting CSV files to the external storage device.</td>
<td>-</td>
</tr>
<tr>
<td>Memory</td>
<td>Valid when [Memory] is set to &quot;Individually&quot;. Set the sampling memory address.</td>
<td>-</td>
</tr>
<tr>
<td>Type/Decimal Point Data Length/Characters Text Process</td>
<td>Set the data type of the specified memory address.</td>
<td>-</td>
</tr>
</tbody>
</table>

Others

Configure settings on this tab to use calculation functions (mean values, total values, etc.) on the sampling data. The settings on this tab do not need to be changed in this section.
♦ **Sampling Control Memory/Information Output Memory**

The sampling control memory is used to control the buffering area and the information output memory is used for outputting the state of the buffering memory.

This completes the configuration of the buffering area settings.
6. SRAM/Clock Settings

SRAM format settings must be configured because [Primary storage target] - [Type] was set to “SRAM” for data retention after the power is turned off. Clock settings must also be configured because the clock display is set to use the internal clock of the TS Series unit.

1. Click [System Setting] → [Unit Setting] → [SRAM/Clock].

2. Configure the following settings in the [SRAM/Clock Setting] dialog box. Do not change any of the other settings.

<table>
<thead>
<tr>
<th>Item</th>
<th>Details</th>
<th>Setting Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Use Built-in Clock</td>
<td>Selected: Use the clock built into the TS Series unit. Deselected: Use the clock in the PLC.</td>
<td>Selected</td>
</tr>
<tr>
<td>SRAM Auto Format</td>
<td>Selected: Automatically format the SRAM area. Deselected: The message “Error:161 (24:) The SRAM area is not formatted.” or “The SRAM/clock setting does not match the SRAM area format.” is displayed when transferring screen data. In this case, execute [Format of SRAM] on the [Main Menu] screen. For more information on the format procedure, refer to “SRAM Format/Clock Settings” on page 5-28.</td>
<td>Selected</td>
</tr>
<tr>
<td>Primary Storage of Sampling</td>
<td>Check the amount of SRAM used for the primary storage target.</td>
<td>-</td>
</tr>
</tbody>
</table>

3. Click [OK]. This completes the configuration of the SRAM and clock settings.
7. Placing Text

Place text on the trend sampling screen.

1. Click the [Text] icon. A cross-shaped cursor is displayed.
2. Click on the screen. A text frame is displayed.
3. Enter text.
4. Click a location on the screen other than the text.
5. Click the text again to display its item dialog box. Change the text color and text size properties.

This completes the screen editing process.
### Checking Operation on the Unit

#### 1. Memory Addresses

The memory addresses used in this example are listed below.

<table>
<thead>
<tr>
<th>Memory Address</th>
<th>Memory Contents</th>
</tr>
</thead>
<tbody>
<tr>
<td>D00000</td>
<td>Read area</td>
</tr>
<tr>
<td>D00001</td>
<td></td>
</tr>
<tr>
<td>D00002</td>
<td></td>
</tr>
<tr>
<td>D00003-04</td>
<td>Sampling control memory (Buffer No. 1)</td>
</tr>
<tr>
<td>D00003-05</td>
<td>T: Trigger</td>
</tr>
<tr>
<td>D00003-06</td>
<td>R: Reset</td>
</tr>
<tr>
<td>D00003-07</td>
<td>Not used</td>
</tr>
<tr>
<td>D00200</td>
<td>U: Start bit</td>
</tr>
<tr>
<td>D00201</td>
<td></td>
</tr>
<tr>
<td>$u16340-04</td>
<td>Sampling memory (Buffer Word No. 0)</td>
</tr>
<tr>
<td>$u16340-05</td>
<td></td>
</tr>
<tr>
<td>$u16340-06</td>
<td></td>
</tr>
<tr>
<td>$u16340-07</td>
<td>Info output memory (Buffer No. 1)</td>
</tr>
</tbody>
</table>

### 1.1 Sampling Control Memory

The sampling control memory is used to control the operation and state of the buffering area function. Allocation and the contents of sample control memory differ depending on settings.

In this example, [Buffering Area separate settings] are not set, so memory from the [Read Area] is allocated consecutively in 3 word blocks from “D0”. In addition, the sampling control memory becomes bit numbers “04” to “07” of “D00003” because buffer number 1 is being used.

<table>
<thead>
<tr>
<th>T</th>
<th>R</th>
<th>S</th>
<th>U</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trigger</td>
<td>Reset</td>
<td>Normal operation bit</td>
<td>Start bit</td>
</tr>
</tbody>
</table>

This bit is only valid when [Type] is set to “Trend” and [Sampling Method] is set to “Bit Synchronization”. History is stored when this bit is “ON”.

When this bit is set to “ON”, data in the specified buffer is cleared and sampling stops. When this bit is set to “OFF”, sampling is started.

This bit is not used when [Type] is set to “Trend”.

This bit is only valid when [Type] is set to “Trend” and [Sampling Method] is set to “Constant Sampling”. Sampling is performed while this bit is set to “ON”.

### 1.2 Sampling Memory

This memory stores the sampling data. The memory used differs depending on the setting of the [Memory] checkbox ( ) in the [Buffering Area Settings] dialog box.

In this example, the sampling memory is “D00200” to “D00201” because the [Memory] checkbox is selected, the memory address is set to “D200”, and [Data Length] is set to “2-Word”.
2. Unit Operation

This section explains how to check screen operation after transferring screen data to the unit.

2.1 SRAM Format/Clock Settings

The message “Error:161 (24:)” is displayed immediately after transferring screen data to a new unit. In this case, execute [Format of SRAM] on the [Main Menu] screen. Also configure the settings for the built-in clock on the same screen.

Subsequent screen data transfers to units that have been formatted will not result in this error.*1 SRAM data is retained until the battery in the unit runs out. If the unit is turned off when the battery has run out, the SRAM data is erased. In this case, reformat the SRAM area.

Unit SRAM Area

SRAM

Error occurs

0
128kbyte

Unformatted (new unit/dead battery)

Perform formatting (Main Menu)

Normal

$L
$LD
Sampling primary storage target
Not used

*1 The case when the [SRAM Auto Format] checkbox is selected in the [SRAM/Clock Setting] dialog box.

For more information on the formatting procedure, refer to “SRAM Format/Clock Settings” on page 5-28.
2.2 Executing Sampling

Execute sampling according to the following procedure.

1. Enter the following constants for “D00200” and “D00201”.
   
   \[
   \begin{align*}
   &D00200 = 17 \\
   &D00201 = 90
   \end{align*}
   \]

2. Set the “D00003-04” bit in sample control memory to “ON” (0 → 1).
   
   \[D00003 = H0010\]
   
   The sample time display and sample count display appear as shown below.

3. Set the “D00003-04” bit to “OFF” (1 → 0).
   
   \[D00003 = H0000\]

4. Set the “D00003-04” bit to “ON” again (0 → 1).
   
   \[D00003 = H0010\]
   
   The trends are displayed. The sample time is updated and the sample count display indicates “2”, as shown below.
5. Proceed to sample the following data.

<table>
<thead>
<tr>
<th>Sample Count</th>
<th>Sampling Data Memory</th>
</tr>
</thead>
<tbody>
<tr>
<td>D00200</td>
<td>D00201</td>
</tr>
<tr>
<td>3</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>65</td>
</tr>
<tr>
<td>4</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>70</td>
</tr>
<tr>
<td>5</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>75</td>
</tr>
<tr>
<td>6</td>
<td>15</td>
</tr>
<tr>
<td></td>
<td>80</td>
</tr>
<tr>
<td>7</td>
<td>16</td>
</tr>
<tr>
<td></td>
<td>70</td>
</tr>
<tr>
<td>8</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>65</td>
</tr>
<tr>
<td>9</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>60</td>
</tr>
<tr>
<td>10</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td>55</td>
</tr>
<tr>
<td>11</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>50</td>
</tr>
<tr>
<td>12</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td>45</td>
</tr>
<tr>
<td>13</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>40</td>
</tr>
<tr>
<td>14</td>
<td>25</td>
</tr>
<tr>
<td></td>
<td>38</td>
</tr>
<tr>
<td>15</td>
<td>24</td>
</tr>
<tr>
<td></td>
<td>40</td>
</tr>
<tr>
<td>16</td>
<td>23</td>
</tr>
<tr>
<td></td>
<td>45</td>
</tr>
<tr>
<td>17</td>
<td>22</td>
</tr>
<tr>
<td></td>
<td>50</td>
</tr>
<tr>
<td>18</td>
<td>21</td>
</tr>
<tr>
<td></td>
<td>55</td>
</tr>
<tr>
<td>19</td>
<td>20</td>
</tr>
<tr>
<td></td>
<td>60</td>
</tr>
<tr>
<td>20</td>
<td>19</td>
</tr>
<tr>
<td></td>
<td>62</td>
</tr>
<tr>
<td>21</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>65</td>
</tr>
<tr>
<td>22</td>
<td>18</td>
</tr>
<tr>
<td></td>
<td>65</td>
</tr>
<tr>
<td>23</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>60</td>
</tr>
<tr>
<td>24</td>
<td>17</td>
</tr>
<tr>
<td></td>
<td>60</td>
</tr>
</tbody>
</table>

Display example where count is “24”
2.3 Operating Switches

Use the switches on screen to check history data.

♦ Roll Up and Roll Down

1. Press the roll down switch. A cursor is displayed in the center of the graph and the [Graph Return] switch starts to flash. The sample count, cursor value, and sample time of the data selected at the cursor is displayed.

2. Pressing the roll down switch again moves the selection cursor to the left. The sample count, cursor value, and sample time are updated.

3. Pressing the [Graph Return] switch causes the cursor to disappear and returns to the latest display.
6. Trend Screen (Trend Sampling)

♦ Zoom In and Zoom Out
Press the [Zoom In] switch to enlarge the display of the latest data (end point) by 2 times. Each time the switch is pressed, magnification increases to 4 times and then 8 times (maximum). Press the [Zoom Out] switch to reduce the display magnification in the order of 8 times → 4 times → 2 times → actual size.

If the cursor is displayed, magnification centers on the cursor.
6. Trend Screen (Trend Sampling)

- **Switch Functions**
  The following switch functions are used in trend sampling.

<table>
<thead>
<tr>
<th>Switch Function</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1 Roll up</td>
<td>Scroll one point toward the newest data. If all data points cannot be displayed in the area, one data point scrolls into view at a time.</td>
</tr>
<tr>
<td>2 Roll down</td>
<td>Scroll one point toward the oldest data. If all data points cannot be displayed in the area, one data point scrolls into view at a time.</td>
</tr>
<tr>
<td>3 Next block</td>
<td>Scroll one page toward the newest data.</td>
</tr>
<tr>
<td>4 Previous block</td>
<td>Scroll one page toward the oldest data.</td>
</tr>
<tr>
<td>5 Graph Return</td>
<td>This button flashes in conjunction with the cursor when any of the roll up, roll down, next block, or previous block switches are pressed. Pressing this switch when it is flashing returns to the latest trend sampling display. At this point, the switch stops flashing and the cursor disappears.</td>
</tr>
<tr>
<td>6 Reset</td>
<td>Press this switch once to turn on its lamp and then press it again within two seconds to clear the contents of the buffering area. Sampling starts again immediately after the buffering area is cleared. If the switch is not pressed again within two seconds, the switch’s lamp turns off and resetting is nullified.</td>
</tr>
<tr>
<td>7 Zoom In</td>
<td>Zoom in on the graph display by 2, 4, and 8 times. Each press doubles the magnification and halves the number of X-axis data points.</td>
</tr>
<tr>
<td>8 Zoom Out</td>
<td>Zoom out of the magnified graph. Each press halves the magnification and doubles the number of X-axis data points.</td>
</tr>
</tbody>
</table>
6. Trend Screen (Trend Sampling)

♦ Numerical Displays

The numerical displays used in trend sampling are shown below.

![Trend Sampling Diagram]

<table>
<thead>
<tr>
<th></th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sampling count display&lt;br&gt;Cursor hidden: Displays the current number of samplings.&lt;br&gt;Cursor shown: Displays the current number of samplings of the data selected with the cursor.</td>
</tr>
<tr>
<td>2</td>
<td>Cursor point value display&lt;br&gt;Displays the cursor point value when the cursor is displayed using the roll up, roll down, next block, or previous block switch. When the cursor is hidden, the latest values of the trend lines are displayed instead.</td>
</tr>
<tr>
<td>3</td>
<td>Sampling time display&lt;br&gt;Indicates the last sampling time or the sampling time of the selected message. Display differs depending on the number of specified digits. Less than 8 digits Hidden. From 8 digits up to 14 digits hour : minute : second. 15 digits or more month - day, hour : minute : second.</td>
</tr>
<tr>
<td>4</td>
<td>Sampling time display&lt;br&gt;(start point of display) Displays the display start time/display end time of the displayed graph.</td>
</tr>
<tr>
<td>5</td>
<td>Sampling time display&lt;br&gt;(end point of display)</td>
</tr>
</tbody>
</table>

---

6-33
7. Screen Data Transfer

This chapter explains how to transfer screen data to the TS Series unit and export screen data from the TS Series unit.

Transfer methods include USB transfer by connecting the TS Series unit and computer with a USB cable, Ethernet transfer, and storage transfer using USB memory.

<table>
<thead>
<tr>
<th>Transfer Method</th>
<th>TS1100i / TS1070i</th>
<th>TS1100 / TS1070</th>
</tr>
</thead>
<tbody>
<tr>
<td>USB</td>
<td>☑</td>
<td>☑</td>
</tr>
<tr>
<td>Ethernet</td>
<td>☑</td>
<td>☒</td>
</tr>
<tr>
<td>External storage device</td>
<td>☑</td>
<td>☑</td>
</tr>
</tbody>
</table>

For more information on storage transfer, refer to the “TS Series Hardware Specifications” and “V8 Series Reference Manual.”

Contents

Screen Data Transfer ........................................................................................................ page 7-2
  1. USB Transfer ............................................................................................................ page 7-2
  2. Ethernet Transfer .................................................................................................... page 7-9
Simulator ...................................................................................................................... page 7-18
  1. Overview ................................................................................................................. page 7-18
  2. Operation ................................................................................................................ page 7-18
Emulator ........................................................................................................................... page 7-22
  1. Overview ................................................................................................................. page 7-22
  2. Operation ................................................................................................................ page 7-23
1. USB Transfer

1.1 Installing the USB Driver

A USB driver must be installed to the computer in advance to perform USB transfer. Install the driver according to the following procedure.

♦ For Windows Vista/7/8
1. Connect the USB-miniB port of the TS series (with power on) to the USB-A port of the computer using a USB cable.

![Diagram of USB connection](image)

2. The USB driver is automatically installed. During installation, the following message is displayed on the computer's taskbar.

![Message of installing device driver software](image)

3. The following message is displayed on the computer's taskbar when installation is finished. When successfully completed, transfer the screen data. Refer to page 7-6.
   If installation has terminated due to an error, reinstall the USB driver. See page 7-4.
   - When successfully completed

![Message of device driver software installed successfully](image)

   - When terminated due to error

![Message of device driver software was not successfully installed](image)
For Windows XP
1. Connect the USB-miniB port of the TS series (with power on) to the USB-A port of the computer using a USB cable.

2. The message “Found New Hardware” and then the driver installation wizard appear on the computer. Select [No, not this time] and click the [Next] button.

3. Select [Install the software automatically (Recommended)] on the [Hardware Update Wizard] and click [Next].

4. Installation of the USB driver starts.
5. Click the [Finish] button on the screen below.

♦ **For OSs earlier than Windows XP**

For more information, refer to the V8 Series Operation Manual.

♦ **When USB driver installation fails**

If automatic installation of the USB driver fails, perform installation by the following procedure.

1. Open the following folder from [My Computer] or [Windows Explorer].
   - For Windows Vista/7/8
     C:\MONITOUCHV-SFT V5\INF
   - For Windows XP
     C:\Program Files\V-SFT V5\INF

2. Double-click “V-SFTV5_USBDriver.exe”.

Smiley: Depending on your computer, the following dialog may be displayed when using Windows Vista/7/8.

Click the [Yes] button.
3. Click the [Next] button on the screen below. Installation of the USB driver starts.

![USB Driver Welcome to the setup for USB Driver]

4. Click the [Finish] button on the screen below.

![USB Driver Install Complete]

USB driver installation is complete. Transfer the screen data.

**Recognition of USB Driver**

When the driver has been installed successfully, the [Device Manager] window shows "Operation Panel - Operation Panel USB Driver".

- **For Windows Vista/7/8**
- **For Windows XP**

This will disappear when TS series and computer are disconnected. If [Other Device] or a mark other than shown above is displayed even while the USB is connected, the USB driver is not recognized. If this happens, uninstall the USB driver and reinstall it.
7. Screen Data Transfer

1.2 Transfer

1. Connect the USB-miniB port of the TS series to the USB-A port of the computer using a USB cable.

2. Click [File] → [Transfer] or click the [Transfer] icon.

3. Set [Transfer Device] to “Display” and [Transfer] to “Screen Data” in the [Transfer] dialog box. Select the [ ] Use Simulator checkbox to use the simulator.

Simulator

If a PLC is not available during debugging, use the simulator to confirm screen operation with only the TS Series unit. The simulator that runs on the computer acts as the PLC. For more information, refer to page 7-18.

Emulator

If a TS Series unit is unavailable, use the emulator to confirm screen operation. The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator acts as the PLC. Refer to page 7-22.
4. Check the [Communication Port] setting. If the setting is "USB", proceed to step 6. If the setting is a serial port or Ethernet IP address, click the [Communication Setting] button and select "USB" under [Communication Port].

5. Click the relevant transfer button to start transferring screen data.

<table>
<thead>
<tr>
<th>Transfer Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC→</td>
<td>Transfer screen data from the computer to the TS Series unit.</td>
</tr>
<tr>
<td>PC←</td>
<td>Export screen data on the TS Series unit to the computer.</td>
</tr>
<tr>
<td>PC↔</td>
<td>Compare the data on the computer with the data on the TS Series unit. Select the [ Text comparison] checkbox to obtain a more detailed comparison result.</td>
</tr>
</tbody>
</table>

6. The following dialog box is displayed in the editor during transfer.

- **PC→**
- **PC← / PC↔**
7. Screen Data Transfer

The screen changes to the main screen and [Transferring Data] is displayed on the unit.
* If the main screen is not displayed and the transfer does not start, manually display the main screen and execute the transfer.

- **PC** → Start communication with the PLC. Check unit operation.
- **PC** ← The exported data is displayed. Save the data to a new file.
- **PC** ↔ The comparison results are displayed.

When transferring to new units, the lamp flashes at the lower left of the five languages screen.
2. Ethernet Transfer

2.1 IP Address Settings

The IP address of the unit must be configured in advance to allow Ethernet communication.

♦ Configuring New Units
1. The following screen is displayed after the power is turned on.


3. Press the [EDIT] switch and configure each setting.
4. Press the [Setting Finished] switch to confirm the IP address. The screen returns to the five languages screen.

This completes IP address configuration. Next, perform screen data transfer.
# Configuring Existing Units

1. The PLC communication screen is displayed after the power is turned on. If a PLC is not connected, the [Communication Error - Timeout] screen is displayed.

2. Press and hold your finger on any of the four screen corners (2 cm squares) for more than two seconds and then release your finger.

3. Next, press any of the remaining corners for more than two seconds within one second of releasing the first corner to display a system menu on the right side of the screen.

The system menu cannot be displayed by holding down your finger on locations corresponding to switches, data displays with switches, display areas, slider switches, scroll bars, or table data displays. Press a corner where these items are not located.

If items are located in all four corners, first change to a screen without items in the way before changing to the main screen.

5. Press the [Main Menu] switch to display the menu.

6. Press the [Ethernet] switch to display the [Ethernet] screen.
7. Press the [EDIT] switch and configure each setting.

8. Press the [Setting Finished] switch to confirm the IP address and return to the [Main Menu] screen.
Check the IP address under [Ethernet Information].
If an error is displayed, recheck the cable and IP address.

This completes IP address configuration. Next, perform screen data transfer.
Executing the “ping” command on the computer is convenient way to check for problems with Ethernet connections.

Checking Using the Ping Command
Example: Check the connection state from the computer when the IP address of the unit is “172.16.200.150”.

Open a [Command Prompt] window on the computer.

Enter “ping 172.16.200.150” on the command line using the keyboard and press the [Enter] key.

The following result is displayed if the unit is connected.

The following result is displayed if the unit is disconnected.

Check the IP address of the unit and computer as well as the connection cable.
2.2 Transferring Screen Data

1. Connect the LAN port on the unit to the computer using a LAN cable.

2. Click [File] → [Transfer] or click the [Transfer] icon.


Simulator
If a PLC is not available during debugging, use the simulator to confirm screen operation with only the TS Series unit. The simulator that runs on the computer acts as the PLC. Refer to page 7-18.

Emulator
If a TS Series unit is unavailable, use the emulator to confirm screen operation. The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator acts as the PLC. Refer to page 7-22.
7. Screen Data Transfer

4. Check the [Communication Port] setting.
   If the setting is Ethernet and the IP address is correct, proceed to step 6.
   If the setting is a serial port or USB, click the [Communication Setting] button and select "Ethernet" under [Communication Port].

5. Click the relevant transfer button to start transferring screen data.

<table>
<thead>
<tr>
<th>Transfer Method</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>PC→</td>
<td>Transfer screen data from the computer to the TS Series unit.</td>
</tr>
<tr>
<td>PC←</td>
<td>Export screen data on the TS Series unit to the computer.</td>
</tr>
<tr>
<td>PC↔</td>
<td>Compare the data on the computer with the data on the TS Series unit. Select the [ ] Text comparison checkbox to obtain a more detailed comparison result.</td>
</tr>
</tbody>
</table>

6. The following dialog box is displayed in the editor during transfer.
   - PC→
   - PC← / PC↔
The screen changes to the Main Menu screen and [Transferring Data] is displayed on the unit.

When transferring to new units, the lamp flashes at the lower left of the five languages screen.

7. The [Transferring Data] display disappears when the transfer is complete.
   - PC→
     Start communication with the PLC. Check unit operation.
   - PC←
     The exported data is displayed. Save the data to a new file.
   - PC↔
     The comparison results are displayed.
7. Screen Data Transfer

1. Overview

If a PLC is not available during debugging, use the simulator to confirm screen operation with only the TS Series unit. The simulator that runs on the computer acts as the PLC.

* The simulator can be used for 1:1 connections between the TS Series unit and a connected device. The simulator cannot be used for 1:n and n:1 connections.
* The simulator cannot be used when the connection device is a barcode reader or slave communication device (V-Link, MODBUS slave).

2. Operation

2.1 Configuring the TS Series Unit

When using the simulator, always configure the unit to [Simulator] instead of [Real machine] (other devices) on the unit itself.

1. Press the [Main Menu] switch to display the menu.

2. Press the [Simulator] switch to display the [Simulator] screen.
3. Configure the settings for [Setting at connection destination] and [Simulation Driver Setting].
   - USB connection
     Select [Simulation] under [Simulation Driver Setting] and press [Setting Finished].
   - Ethernet connection
     Set the IP address of the computer under [Setting at connection destination]. Do not change the port number. Select [Simulation] under [Simulation Driver Setting] and press [Setting Finished].
7. Screen Data Transfer

4. Press the [Main Menu] switch to display the menu.

5. Press the [RUN] switch to display the [RUN] screen.
2.2 Simulator

1. Click [View] → [View] → [Simulate] or click the [Simulate] icon.

2. The simulator starts and the relevant screen is displayed on the TS Series unit.

3. Confirm screen operation on the TS Series unit. In addition, changing values on the simulator updates the display on the unit.

   For more information on simulator operation, refer to the “V8 Series Operation Manual.”
7. Screen Data Transfer

1. Overview

If a TS Series unit is unavailable, use the emulator to confirm screen operation. The TELLUS emulator that runs on the computer acts as the TS Series unit and the simulator acts as the PLC.

**Emulator**
- Shows a representation of unit screen display on the computer

**Simulator**
- Implements memory operations instead of the PLC
2. Operation

1. Click [File] → [Start Emulator].

2. The simulator and TELLUS emulator start automatically.

3. The same operations of pressing switches on the unit can be performed by clicking switches on the emulator. In addition, changing values on the simulator updates the display on the emulator.

For more information on simulator operation, refer to the “V8 Series Operation Manual.”
Please use this page freely.
Hakko Electronics Co., Ltd.
www.monitouch.com

Sales 890-1, Kamikashiwano-machi, Hakusan-shi, Ishikawa, 924-0035 Japan
TEL +81-76-274-2144  FAX +81-76-274-5136